loud single screech from speakers - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-19-2008, 08:54 PM Thread Starter
BenzWorld Junior Member
Date registered: Mar 2008
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question loud single screech from speakers

I have a 2004 CLK500 and on several occasions (10 times in one month) I hear a sound like a “big” rock is hitting my car. When it happens it only happens for a few seconds and goes away for 4 or 5 days. I don’t have to be driving the car when this occurs, I’ve been at a stop sign and it screeches. I’m pretty sure I hear the noise coming through my car speakers, but I’m not sure. After this happened today, my remote would not unlock my trunk or door locks. After, unlocking manually, it worked fine. Anyone know what this could be? Is it serious? Maybe an electrical short? No malfunctions. Thanks 
mbcspr is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Screech sound on Startup SDragon W124 E,CE,D,TD Class 0 06-02-2007 10:36 AM
    Screech now a porn star Nutz 4 Benz Off-Topic 18 09-28-2006 06:07 PM
    Left side speakers not as loud as right jafo1994 W201 190-Class 1 05-24-2006 08:59 AM
    A/C screech janos_z W126 S,SE,SEC,SEL,SD,SDL Class 9 04-13-2005 11:09 PM
    Loud tone from radio when car starts/tele-aid loud as well peclark Audio & Telematics Forum 4 05-08-2004 07:59 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome