omg what is happening - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 05-16-2008, 11:45 PM Thread Starter
BenzWorld Newbie
 
Date registered: May 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
omg what is happening

i was driving my benz ml350 2008 and suddenly check engine sign turned on. my parents are eager to take it to the dealer and it may cost money to check whats going on and the place wont open till monday and i have work tomorrow. but before i do that, did anyone else here encounter the same problem?? and how was it fix??? please!! i need answers!! how do i check my codes??

Last edited by bookstore; 05-17-2008 at 01:04 AM.
bookstore is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 05-16-2008, 11:54 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,751
Mentioned: 9 Post(s)
Quoted: 1119 Post(s)
CEL usually is triggered by emmision or engine management system. Usually you can drive with it for a while but not knowing what it is you are taking your chances. Might be loose gas cap, or bad MAF sensor. Check the codes to learn more what is it.
Kajtek1 is offline  
post #3 of 7 (permalink) Old 05-17-2008, 05:42 AM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,281
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
You can have the codes read for free at Advance Auto etc. Post the codes here. Since your vehicle is likely under warrenty I would not worry too much.

Mike
Michael Pillay is offline  
post #4 of 7 (permalink) Old 05-17-2008, 07:39 AM
BenzWorld Elite
 
MY2008ML350's Avatar
 
Date registered: Mar 2008
Location: Greater Toronto Area, Ontario, Canada
Posts: 1,328
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by bookstore View Post
i was driving my benz ml350 2008 and suddenly check engine sign turned on. my parents are eager to take it to the dealer and it may cost money to check whats going on and the place wont open till monday and i have work tomorrow. but before i do that, did anyone else here encounter the same problem?? and how was it fix??? please!! i need answers!! how do i check my codes??
Don't worry too much it's still under warranty Just in case there is a problem with your emission system (which is unlikely) , they have to replace it.
Probably a loose gas cap. When you have the CEL reset, the next time you're filling up, make sure to turn the gas cap a few times; you should hear 3 clicks.

*************************************
2010 B200, Polar Silver, Premium Pkg
2008 ML350, Obsidian Black, Premium Pkg
2008 C300, Calcite White
2007 C230, 040 Black, Premium Pkg (gone)
MY2008ML350 is offline  
post #5 of 7 (permalink) Old 05-17-2008, 07:40 AM
BenzWorld Member
 
Date registered: Nov 2007
Vehicle: 2006 S500 4Matic
Location: Portland, OR, US
Posts: 177
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
+1 on checking the gas cap. Once I put the cap on but did not close it until it clicked and the Check Engine light came on. Tightened the cap and the light went off (can't remember if it was instantly or just quickly). The fuel system expects a tight seal and if that doesn't exist, the warning light comes on.
bmurphywa is offline  
post #6 of 7 (permalink) Old 05-17-2008, 09:29 AM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,751
Mentioned: 9 Post(s)
Quoted: 1119 Post(s)
Usually after fixing the problem it takes about 7 restarts for CEL to go off. That what happened when I replaced MAF at least.
Kajtek1 is offline  
post #7 of 7 (permalink) Old 05-17-2008, 10:23 AM
BenzWorld Member
 
BlkCL500's Avatar
 
Date registered: Oct 2007
Vehicle: '04 Black CL500, "06 White ML350, '98 Red Boxster
Location: Trinity, Florida
Posts: 124
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I had an 06 ML350 and I filled the car while it was running once.....

The check engine light took 5-6 restarts to go away for me as well.

"Roll that beautiful bean footage!"
BlkCL500 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Why does this keep happening to me... :) billabongo W126 S,SE,SEC,SEL,SD,SDL Class 8 09-17-2007 09:24 PM
    It keeps happening.... reallife R171 SLK-Class 11 04-25-2006 09:10 PM
    What is happening to me?!? WannaBenz R171 SLK-Class 8 08-15-2005 11:34 PM
    OMG OMG.. my car is on its way! da_nailgun R171 SLK-Class 8 04-22-2005 05:06 PM
    this cant be really happening CMcD G-Class 20 01-17-2005 07:16 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome