190E Turn Signals - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-29-2008, 08:08 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
190E Turn Signals

I have a problem with the turn signals on my 84 190e 2.3. I tried the turning on the turnsignal and then turning on the safety flasher then turning it off which fixed my original problem of both turn signals not working.
Now the right turn signal is not working and making a slight buzzing noise when i turn it on. I am thinking that I just need to replace the hazard light switch. Could this be caused by anything else. Help!
Bennys84benz is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-29-2008, 11:03 AM
MTI
BenzWorld Elite
 
MTI's Avatar
 
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
When both left and right turn signals don't respond, then the standard test is to see if the hazard switch activates the signals. If they respond, then it rules out the electrical circuit, which covers the fuse, bulbs, grounds and flasher relay. The hazard switch is the usual culprit.
MTI is offline  
post #3 of 4 (permalink) Old 04-29-2008, 01:30 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Would a bad hazard switch account for only one turn signal not working. I am also having a problem with the intermittant wipers. The slow and fast constant speed on the wipers currently work but the intermittent does not. I am thinking that it may be the combination relay. Because the wipers, hazard, turn signals and the rear defrost is on that relay. I also believe that the rear defroster does not work either. I was told by a MBZ parts guy that only parts of that combo relay can go out leaving some functions working properly ie.. left turn signal and flashers. Can this be the case?
Bennys84benz is offline  
post #4 of 4 (permalink) Old 04-29-2008, 03:24 PM
MTI
BenzWorld Elite
 
MTI's Avatar
 
Date registered: Aug 2002
Vehicle: '85 2.3-16 '99 C280 '11 GLK350
Location: Scottsdale, Arizona, USA
Posts: 4,805
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
With those added symptoms it could be the combination relay . . . or the multifunction stalk on the steering column. It's easiest to remove, inspect, clean and reseat the combo relay in the fuse box to see if it's just a bad electrical contact. I would also remove and clean the hazard switch also.
MTI is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Turn signals BikerBenz R129 SL-Class 2 02-16-2008 02:14 PM
    Smart Key Combination to Turn off Turn Signals Magic Man General Mercedes-Benz 0 09-10-2007 10:04 AM
    my turn signals wont turn off SLICKSLK007 W203 C32 AMG, C55 AMG 2 10-18-2006 07:06 PM
    For once and for all, what is bulb size of rear turn signals and front signals? Black98SLK230 R170 SLK-Class 5 01-27-2004 10:15 AM
    Turn Signals BrabusNYC W220 S-Class 0 01-15-2004 11:52 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome