1996 E230 Earth Problem (maybe) - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 04-10-2008, 01:03 AM Thread Starter
BenzWorld Newbie
Date registered: Apr 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1996 E230 Earth Problem (maybe)

I have a Mercedes E230 1996 and it wll not start on its own. The starter motor clicks when I turn the engine over as if has jammed, and the battery is fully charged. However If I get a jump start from another car,the car starts up straigh away despite the other car not even running. so this rules out the stsrter motor being jammed. I think it maybe an earth connecting as it was fine the other day when I parked up and now its not running and the battery isnt losing any charge. can someone point me in the direction of earth points to check.
Your help is appreciated.

hoodycrow is offline  
Sponsored Links
post #2 of 3 (permalink) Old 04-10-2008, 02:22 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,510
Mentioned: 9 Post(s)
Quoted: 1057 Post(s)
Earth meaning power ground?
Sounds like you have bad cable connection somewhere. You can track the cables with control light, or voltmeter when somebody clicks the ignition.
Most likely that would be battery clamps. Also look for some sign of the heat on the cables.
BTW Welcome to the forum.

Last edited by Kajtek1; 04-10-2008 at 02:27 AM.
Kajtek1 is online now  
post #3 of 3 (permalink) Old 04-10-2008, 02:43 AM
BenzWorld Elite
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
just cause your battery has a full charge doesnt mean its strong enough to start the car. your battery may be dropping too many volts to start the car. the starter draws alot of amps at startup and if one cell in the battery is weak, the amperage is enough to kill the battery. i can already say that because if you connect to another battery to start and it starts, your battery is too weak. try changing your battery and test it again. if you have a meter see what the voltage is at the battery while you try to start.
Streetglower is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    My 1997 E230: SRS light on, problem? d52232dole W210 E-Class 0 06-10-2007 07:07 AM
    MB e230 1996 Radio Code! eJuicy Audio & Telematics Forum 13 03-15-2007 08:53 PM
    Merc E230 1996 P - Where is the Coolant Tank Nadster General Mercedes-Benz 1 05-25-2006 12:58 PM
    problem in E230 WALEED2 W210 E-Class 9 03-26-2006 11:31 PM
    earth problem 1960del Vintage Mercedes-Benz 0 08-17-2004 07:49 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome