1999 e320 Dies while driving - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 04-04-2008, 03:48 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2008
Vehicle: 1999 e320
Location: Louisville, KY
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
1999 e320 Dies while driving

Hello - I have a 1999 e320. Accidentally put in a 1/2 tank of regular gas. 7 days later while driving thru city the car died. I was accelerating in between blocks, it died and started shaking until I stopped. Tried to restart immediately, no luck, it just kept trying to turnover. Tried again 1 hour later, it started right up, drove 3 blocks, died at stoplight. Tried to restart immediately, no luck, it just kept trying to turnover. Again, wait 1 hour, starts right up, this time I do everything (put in neutral at lights, etc) to make sure I'm constantly on the gas pedal the whole way home.

I hooked up OBDII and get P170 & P173 - "Fuel Trim Malfunction" Bank1 & Bank2. NO CEL light is on. Never has been.

I've read this forum and from that I believe it could be MAF (but typically there is CEL on), bad fuel injectors(?), just add fuel cleaner and keep driving, ?.

I just want to be sure it doesn't die on me again while driving down the road (ie Interstate driving).

Thanks for you advice and help.
torrey73 is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 04-05-2008, 01:12 AM
BenzWorld Junior Member
 
Fix The Wire's Avatar
 
Date registered: Apr 2008
Location: Asia
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
what is the fuel pressure? 5-6 bar are necessary.
Did you ever change the fuel filter?

Check also the engine wiring, it tends to become crumby on this model.
Fix The Wire is offline  
post #3 of 7 (permalink) Old 04-05-2008, 06:52 AM
BenzWorld Veteran
 
E-Class Owner's Avatar
 
Date registered: May 2007
Vehicle: 2003 Mercedes Benz E500
Location: San Francisco Bay Area
Posts: 657
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Ah...

that problem was well know on the W124s and very early W210 models, but was rectified well before the 1999 production date of the OPs vehicle.

Nice marketing attempt, though...

JR
E-Class Owner is offline  
 
post #4 of 7 (permalink) Old 04-05-2008, 07:45 AM
BenzWorld Member
 
Date registered: Feb 2008
Posts: 175
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
[QUOTE=torrey73;2823720]Hello - Tried again 1 hour later, it started right up, drove 3 blocks, died at stoplight. Tried to restart immediately, no luck, it just kept trying to turnover. Again, wait 1 hour, starts right up, this time I do everything (put in neutral at lights, etc) to make sure I'm constantly on the gas pedal the whole way home.
QUOTE]

I had the exact same symptoms except that I did not use the wrong gas. Just by chance I fill up two cars within an hour of each other from the same pump. Both cars exhibited the same symptoms as yours. Resolution for both cars came only after the fuel in the tanks was replaced.

For the one car, it took me a long time to diagnose. I could improve on it by working on the car, but never really fixed it. After I figured out what was the cause, for the second car, I just replaced the fuel, and all was well.

I have not gone back to that gas station again.
techyiam is offline  
post #5 of 7 (permalink) Old 04-05-2008, 10:55 AM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 361
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
There are many things that could cause the problem you are talking about. For you adaptations it is possible its the MAF but those codes are not difinitive. You could have got a bad tank of fuel, simply using regular wouldnt cause the problems you are talking about. For a problem like this if you are not experienced at automotive diagnosis you should take the vehicle to a professional.
kyle21nluvnit is offline  
post #6 of 7 (permalink) Old 04-05-2008, 07:29 PM
BenzWorld Member
 
Date registered: Feb 2008
Posts: 175
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I would suspect that it can be quite costly to bring in a car to get fixed with a problem like what I had.

I guess what you could consider first is to used up the gas already in the tank (or as much as reasonable I suppose) if possible, and then fill it up with a high quality gas, preferrably from a gas station with a lot of traffic and is fairly new.

Then if it shows improvement, then you know what to hope for.
techyiam is offline  
post #7 of 7 (permalink) Old 04-10-2008, 07:04 PM
BenzWorld Junior Member
 
Date registered: Apr 2008
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
It also could have nothing to do with fuel at all, and could be your crankshaft position sensor. They usually fail when the engine warms up, causing it to stall. Then when you let it cool for about an hour, it fires right up. ALSO, crankshaft position sensors can and will fail without setting a code or turning on the C.E.L.
benztech269 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
99 e320 dies while driving torrey73 W210 E-Class 4 04-04-2008 05:33 PM
Issue: Car Dies while Driving? milo55041 W202 C-Class 7 09-15-2007 08:12 PM
1999 c280 just dies please help me mazda9683 General Mercedes-Benz 2 05-20-2007 08:33 AM
1999 500SL Dies on road--twice!!! Luckyguy R129 SL-Class 12 05-16-2007 09:50 AM
Engine dies when driving fast or up-hill privremena_adresa General Mercedes-Benz 20 11-01-2006 07:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome