Loss of acceleration-2003 CLK 430 - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 04-03-2008, 02:49 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Loss of acceleration-2003 CLK 430

I have experienced a one time event of a loss of acceleration on my CLK. This loss occurred both on the highway and local roads. After turning the motor off and restarting, the problem has disappeared--for the time being. No dashboard light or messages appeared.

Any ideas or suggestions on what may have caused this problem.
minoter is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 04-03-2008, 02:58 PM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 361
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
I will try to help where I can. First fill out your profile please . I do need a little more info to help you though. When you went to accel, did you floor it or just get into it a little more than usual? An incorrect reading from the MAF could cause a temporary power loss. Its pretty hard to diag a problem like this without actually having the vehicle in front of me though.
kyle21nluvnit is offline  
post #3 of 5 (permalink) Old 04-03-2008, 03:12 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I actually first noticed the problem when I floored the pedal to get onto the highway. After getting off the highway (about 10 minutes later), I had to floor it at a stop light just to pick up speed to move with traffic. As I said, after getting home and restarting the car (5 minutes later) the problem disappeared.

Sorry, I will complete a profile.

Thanks
minoter is offline  
post #4 of 5 (permalink) Old 04-03-2008, 03:18 PM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 361
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Well like I said its hard to diagnose without riding in the vehicle as different types of power loss are hard to describe but easy to feel . I would go ahead and clean the MAF just to know its done. If you dont have any other issues I would leave well enough alone. If it happens again I think you need to talk with a tech in person so they can ride with you. Sorry i couldnt be much help on here.
kyle21nluvnit is offline  
post #5 of 5 (permalink) Old 04-09-2008, 03:50 AM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2008
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Acceleration Problem solved

It turns out there is an accelerator electronic sensor on the accelerator pedal on my clk 430. MB changed it and problem was solved. This is my 1st repair under the 3 year extended warranty which began 6 months ago. Looks like that warranty was a good purchase.
minoter is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    2003 C230 loss in power/ acceleration...Plz help. ammar_rage W203 C-Class 17 08-26-2009 02:48 PM
    Front tow clip cover 2003 CLK 430 walterf C208/A208 CLK-Class 3 08-21-2006 08:23 PM
    Help me choose wheel and tire package for 2003 CLK 430 charley101 The Discount Tire Direct Tire, Wheel, Brake & Suspension 1 07-13-2006 11:23 AM
    Nav system for 2003 clk 430 firestar60615 C208/A208 CLK-Class 4 07-10-2006 07:35 AM
    WHERE DO I FIND PICTURES OF 2003 CLK 430????? DESCOM12 C208/A208 CLK-Class 1 06-13-2001 04:24 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome