Indicator lights fault - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-24-2008, 01:52 PM Thread Starter
BenzWorld Newbie
Date registered: Mar 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Indicator lights fault

My V230's indicator/hazard lights have just stopped working (they don't light up at all). The intermittent wash/wipe has coincidentally stopped working. The indicator light in the instrument binacle lights up when the indicator stalk is moved up or down or the hazard light switch is pushed but it does not blink. I have changed all the bulbs (front, rear and side) and the fuses are fine. Could it be the relay (located, I believe under the passenger seat)? If so, how do you identify the relevant relay. If it is not the relay, what else could it be? Any ideas very gratefully received.
leighw is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    ETS light on the Dash(Fault indicator?) iriaanenih W163 M-Class 3 07-25-2007 11:33 PM
    turn indicator/hazard lights fault? silver50 R129 SL-Class 1 01-27-2007 06:28 PM
    BAS/ESP & ABS Fault Indicator Light On rca918 Vintage Mercedes-Benz 0 04-27-2006 04:18 AM
    Non-flashing indicator lights Luc SLK (UK) R170 SLK-Class 2 07-10-2005 10:49 AM
    indicator lights went haywire on me.. help JD32 R170 SLK-Class 3 04-14-2004 07:41 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome