GL450 2007model ignition fault? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-22-2008, 07:29 AM Thread Starter
BenzWorld Newbie
 
Date registered: Mar 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
GL450 2007model ignition fault?

hey guys,

I was driving my GL450 2007 model when i noticed the fuel guage went from quarter to zero. I thought it was a problem with the guage so i stopped the engine and restarted hoping the guage would come up but the car didnt even start!

I got message 'remove key'

I tried again after a few days and it started normally but everytime i stopped the car, it would take several hours before the car would restart!!!

It highly frustrating especially as i shipped the car now from the states to nigeria and it is still under manufacturers warranty.

Any ideas?
champee2000 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    1995 c280 ignition fault Colos General Mercedes-Benz 2 10-28-2007 12:58 PM
    ignition lock cylinder & ignition switch lakeside W164 M-Class 2 07-23-2007 06:55 PM
    GL450 parked with transmission fault LDH X164 GL-Class 3 03-23-2007 07:52 PM
    Diagnosing ignition fault 1990 560sec mikesmerc W126 S,SE,SEC,SEL,SD,SDL Class 3 11-25-2005 06:50 AM
    My fault? MB's fault? ML320ML W163 M-Class 8 02-08-2004 08:19 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome