Interesting Problem, thoughts please - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 03-21-2008, 06:02 AM Thread Starter
BenzWorld Junior Member
 
patpur's Avatar
 
Date registered: Sep 2007
Vehicle: 2004 C240 4Matic
Location: Brookeville, Maryland
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Interesting Problem, thoughts please

Last night I went out to move our 04 240 4 matic and none of the gauges were working, also no heat, none of the accessories except the door lock button. The lights do work and I ran the car around the block and it seemed to run fine. I pulled it back in the driveway and shut it off. About a minute later I restarted the car and everything worked but now I was getting a "check engine" light. Left the car for the night and tried it again this morning and same thing. Start it no gauges same deal. Shut it off, turned it back on and everything works again but there is the check engine light. My wife took the car to work which is a short distance. I will call the dealer but anyone have any idea at what we might be looking at here?
As always thanks in advance.
Pat
patpur is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 03-21-2008, 09:46 AM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 361
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
There is really no telling what is wrong without being able to hook up to the vehicle. Sorry man the dealer or a Benz shop is probably your only option to figure this one out.
kyle21nluvnit is offline  
post #3 of 7 (permalink) Old 03-21-2008, 10:31 AM Thread Starter
BenzWorld Junior Member
 
patpur's Avatar
 
Date registered: Sep 2007
Vehicle: 2004 C240 4Matic
Location: Brookeville, Maryland
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Goes in Monday. I just hope its something simple. We love the car but this back and forth is getting a bit old. If it keeps up I might have to buy a new one!
patpur is offline  
post #4 of 7 (permalink) Old 03-21-2008, 12:22 PM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
Generally speaking, when you have a mass failure of seemingly unrelated components, I'd check two things:

1. Ground.

2. Hot position of the ignition switch. It seems like everything that's not working is the stuff that needs the ignition switch in "Hot" position.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #5 of 7 (permalink) Old 03-21-2008, 02:59 PM Thread Starter
BenzWorld Junior Member
 
patpur's Avatar
 
Date registered: Sep 2007
Vehicle: 2004 C240 4Matic
Location: Brookeville, Maryland
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks. If its a bad ignition switch the dealer will have to get into that. I'll check the ground but much past the one that comes off the battery I'm lost.
Fortunately the car is certified so its on MB to find it and fix it.
Pat
patpur is offline  
post #6 of 7 (permalink) Old 03-22-2008, 07:41 AM Thread Starter
BenzWorld Junior Member
 
patpur's Avatar
 
Date registered: Sep 2007
Vehicle: 2004 C240 4Matic
Location: Brookeville, Maryland
Posts: 14
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Well I found the problem. The fuse box that sits by the master cyl. was not closed properly and some tree debris got in there. I blew it out, made sure all the connections were tight. One of the wire bundle connectors was a bit loose. I buttoned it back up correctly and no more problem. Car did fine last night and this morning.
Pat
patpur is offline  
post #7 of 7 (permalink) Old 03-22-2008, 08:59 PM
BenzWorld Elite
 
flyboyike's Avatar
 
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,699
Mentioned: 1 Post(s)
Quoted: 68 Post(s)
Quote:
Originally Posted by patpur View Post
Well I found the problem. The fuse box that sits by the master cyl. was not closed properly and some tree debris got in there. I blew it out, made sure all the connections were tight. One of the wire bundle connectors was a bit loose. I buttoned it back up correctly and no more problem. Car did fine last night and this morning.
Pat
Imagine that.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Your thoughts on my cruise control problem Brix W202 C-Class 0 09-21-2007 05:03 PM
    Interesting information on my car, any thoughts on these options? slybydesign W210 E-Class 5 08-08-2007 03:30 PM
    problem with NAV, any thoughts? Carl Osborne C208/A208 CLK-Class 4 04-04-2007 06:13 PM
    280GE Problem-Looking for any Thoughts Big Red G G-Class 7 01-21-2005 10:38 AM
    Interesting new problem, or is it a problem? My car's water broke yesterday Jason Y R170 SLK-Class 8 06-13-2001 07:54 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome