03 R230 SL500 Help! onboard computer going crazy! - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 03-18-2008, 07:07 PM Thread Starter
BenzWorld Junior Member
 
98 SLK230 US's Avatar
 
Date registered: Oct 2003
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Lightbulb 03 R230 SL500 Help! onboard computer going crazy!

Any advice would be appreciated. This being said here is my issue. I get SOS malfunctions, ABC, electric consumers offline, ABS light comes on. When one stops another starts. Could this just be a faulty ground wire or possibly some kind of corrosion causing this. The systems all seem fine and work properly but the warnings keep coming every few weeks.
98 SLK230 US is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 03-19-2008, 02:44 AM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
you first need to check your charging system (batteries first). the control units on your car cant handle low voltage.
Streetglower is offline  
post #3 of 5 (permalink) Old 03-19-2008, 11:49 AM
BenzWorld Member
 
Date registered: Mar 2008
Vehicle: CLS550 Master Lease, 1990 300zxTT, 2000 camry
Location: Augusta, Ga
Posts: 361
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Yes charging and starting system is very important with this vehicle. You have two batteries to run different systems at different times. I would definatly start with having the batteries checked and the charging system checked. If those test good then start looking for other problems.
kyle21nluvnit is offline  
post #4 of 5 (permalink) Old 03-19-2008, 06:06 PM
BenzWorld Junior Member
 
Date registered: Mar 2008
Location: RSM, CA
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
if the car starts ok than its not the front battery, this battery is for starting only. More than likely it needs a new systems battery which is in the trunk. Is the light in blue or red when its on the cluster? blue = battery is low on charge. red = charging system
MB_Tech is offline  
post #5 of 5 (permalink) Old 01-04-2009, 12:54 PM Thread Starter
BenzWorld Junior Member
 
98 SLK230 US's Avatar
 
Date registered: Oct 2003
Posts: 9
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Disconnecting SOS

Thanks for the help! It was the rear battery. Apparently the SOS has a problem that causes the system to continuously try to call for help and that killed the battery. Any advice on disconnecting the SOS?
98 SLK230 US is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    R230 (SL500) Parts For Sale alexx R230 SL-Class 0 01-27-2008 05:47 PM
    Original SL500 wheels w/tires R230 WPFAST For Sale/Wanted/Trade/Giveaway 0 08-25-2007 01:02 PM
    Exhaust R230 SL500 sirrone R230 SL-Class 4 09-03-2006 10:22 AM
    560SEL rare onboard computer info needed mutley666 W126 S,SE,SEC,SEL,SD,SDL Class 2 07-16-2005 12:03 PM
    Upgrade to onboard computer Ben Kokes R170 SLK-Class 12 05-09-2002 09:17 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome