C1120 N64 ESP yaw rate sensor.zero point offset error of component - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 12 (permalink) Old 03-11-2008, 08:06 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: Proton Saga BLM
Location: Sabah-Malaysia
Posts: 64
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to jrkong Send a message via Skype™ to jrkong
(Thread Starter)
C1120 N64 ESP yaw rate sensor.zero point offset error of component

Hi all,ESP pops up in the instrument cluster.i ran short test by star diagnostic.below was the result:
C1120 N64 ESP yaw rate sensor.zero point offset error of component N64.
I tried to press the ESP button,but the symbol in the instrument cluster doesn't go out. Can you give me any tips to solve this problem.
jrkong is offline  
Sponsored Links
Advertisement
 
post #2 of 12 (permalink) Old 03-11-2008, 08:24 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by jrkong View Post
Hi all,ESP pops up in the instrument cluster.i ran short test by star diagnostic.below was the result:
C1120 N64 ESP yaw rate sensor.zero point offset error of component N64.
I tried to press the ESP button,but the symbol in the instrument cluster doesn't go out. Can you give me any tips to solve this problem.
You can try to reset this one but it needs star diagnostics to preset the test programme. Once the programme is put in test mode, then you must road test the car and perform the re set, ie drive the car for 10 km in a straight line and then swerve left and right for 100M, then do a u turn. The last one I did took five tests before it worked.

The yaw rate sensor is very sensitve and sometimes the reset works but most times the sensor has to be changed and if you dont have star D then you will have to take it to the stealers or a specialist.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #3 of 12 (permalink) Old 03-11-2008, 09:17 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: Proton Saga BLM
Location: Sabah-Malaysia
Posts: 64
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to jrkong Send a message via Skype™ to jrkong
(Thread Starter)
Unhappy

thanks for your reply eric.i retrieved the TDC by DAS.i performed road test for few times.but still the same fault.now even worse..ROAD TEST:ACTIVE shown on the DAS.what is the problem?DAS requested me to perform road test again. and BAS,ABS,EPS NOT AVAILABLE DIAGNOSE. /RIG TEST.shown on the instrument cluster now.what is going on eric..please..
jrkong is offline  
post #4 of 12 (permalink) Old 03-11-2008, 09:20 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: Proton Saga BLM
Location: Sabah-Malaysia
Posts: 64
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to jrkong Send a message via Skype™ to jrkong
(Thread Starter)
may i know what is the actual value for the yaw rate sensor when the car is in standstil condition?it was 19.1.
jrkong is offline  
post #5 of 12 (permalink) Old 03-11-2008, 09:34 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by jrkong View Post
thanks for your reply eric.i retrieved the TDC by DAS.i performed road test for few times.but still the same fault.now even worse..ROAD TEST:ACTIVE shown on the DAS.what is the problem?DAS requested me to perform road test again. and BAS,ABS,EPS NOT AVAILABLE DIAGNOSE. /RIG TEST.shown on the instrument cluster now.what is going on eric..please..
Did you follow the proceedure as per das instructions, ie switch ESP off before perfoming the test? This is a complex test and may need to be performed several times before it works. You must swerve the car left and right (quite violently) during the test. And road test Active means you have not completed the test. ESP BAS ABS will not be available during the test cycle its normal.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.

Last edited by eric242340; 03-11-2008 at 09:41 AM.
eric242340 is online now  
post #6 of 12 (permalink) Old 03-11-2008, 06:39 PM Thread Starter
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: Proton Saga BLM
Location: Sabah-Malaysia
Posts: 64
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to jrkong Send a message via Skype™ to jrkong
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
Did you follow the proceedure as per das instructions, ie switch ESP off before perfoming the test? This is a complex test and may need to be performed several times before it works. You must swerve the car left and right (quite violently) during the test. And road test Active means you have not completed the test. ESP BAS ABS will not be available during the test cycle its normal.
actually i accidentally done the road test.but yesterday i tried to run road test again,it came out again.i follow the instructions given.maybe i haven't completely done the road test.may i know what is the actual value of the yaw rate sensor when the car is in standstil condition?
jrkong is offline  
post #7 of 12 (permalink) Old 03-11-2008, 11:26 PM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Ive been thinking about your problem and a few points that came to mind but:
1. Has the sensor been changed?
2. Was the battery disconnected?
3. Has the steering angle sensor been reset?
4. What is the vehicle model and year clk/slk?

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #8 of 12 (permalink) Old 03-12-2008, 08:22 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: Proton Saga BLM
Location: Sabah-Malaysia
Posts: 64
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to jrkong Send a message via Skype™ to jrkong
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
Ive been thinking about your problem and a few points that came to mind but:
1. Has the sensor been changed?
2. Was the battery disconnected?
3. Has the steering angle sensor been reset?
4. What is the vehicle model and year clk/slk?
1.I haven't change the sensor yet.i will change it tomorrow.
2.i disconnected the battery negative terminal for few times,it was still the same when i connected the terminal.
3.yes,i done the harmonization of the steering angle.
4WDC2030452R013707
jrkong is offline  
post #9 of 12 (permalink) Old 03-12-2008, 08:33 AM
Outstanding Contributor
 
eric242340's Avatar
 
Date registered: May 2007
Vehicle: Zotye Auto 1.5T T600 2016
Location: The wild west of the Far East
Posts: 52,189
Mentioned: 3 Post(s)
Quoted: 291 Post(s)
Quote:
Originally Posted by jrkong View Post
1.I haven't change the sensor yet.i will change it tomorrow.
2.i disconnected the battery negative terminal for few times,it was still the same when i connected the terminal.
3.yes,i done the harmonization of the steering angle.
4WDC2030452R013707
In this case change the sensor first and then look again, you are moving in the right direction im sure.

ERIC.

___________________________________________
"I am enclosing two tickets to the first night of my new play; bring a friend, if you have one."
- George Bernard Shaw to Winston Churchill.

"Cannot possibly attend first night, will attend second ... if there is one."
- Winston Churchill, in response.
eric242340 is online now  
post #10 of 12 (permalink) Old 03-12-2008, 08:40 AM Thread Starter
BenzWorld Member
 
Date registered: Sep 2006
Vehicle: Proton Saga BLM
Location: Sabah-Malaysia
Posts: 64
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via MSN to jrkong Send a message via Skype™ to jrkong
(Thread Starter)
Quote:
Originally Posted by eric242340 View Post
In this case change the sensor first and then look again, you are moving in the right direction im sure.
i will let you know the result tomorrow.hey man,you from shenzhen?chinese?
jrkong is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Yaw Rate Sensor and ESP/BAS light Dting22 W163 M-Class 150 04-06-2016 12:28 AM
    C1120 N64 ESP yaw rate sensor.zero point offset error of component jrkong W203 C32 AMG, C55 AMG 2 03-11-2008 06:42 PM
    99 ML430 YAW Rate Sensor mlCharlie W163 M-Class 1 09-22-2006 02:49 PM
    Is this Considered Dangerous-C1120 ESP Yaw Sensor Code? TankNoir W140 S-Class 1 05-27-2006 08:55 AM
    Yaw rate sensor - 1998 C280 aes1128 W202 C-Class 1 07-05-2004 11:44 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome