98 E320 Wagon Misfire - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-12-2008, 11:47 AM Thread Starter
BenzWorld Junior Member
Ben Parrish's Avatar
Date registered: Feb 2008
Vehicle: 1998 E320 Wagon
Location: Rabun, Co GA
Posts: 12
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
98 E320 Wagon Misfire

I have a 98 320 Wagon with 110,000 on the clock. Recent check engine light with CCheck Engine Electronics. Had the codes pulled and had a misfire on cyl 1, and 3. Replaced plugs and had rechecked. Same codes but with the addition of cyl 2. Just replaced the coils and wires for 1,2 and 3 and had codes re-read...still the same. I took it for a twenty minute highway drive and all seemed fine; the car ran smoothly and strong. Stopped and re-started the car and the lights were off. GREAT...
Accelerated down the road and once the rpm's went over 5k, cel lights flash and car goes into limp mode. I pull over and turn the car off and restart. Lights are still on but the car is running well again. Once again accelerate and when it hits 5k the limp mode starts and I repeat the process.
I have now disconnected the battery an am waiting 30 min to see what happens.
Any idea WHERE TO GO FROM HERE? I have an OBD coming but all it is going to tell me is that 1,2 and 3 are misfiring. Can't figure out why it runs great till 5k and then goes into limp mode???
Any help greatly appreciated.

Ben Parrish is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    94 E320 Wagon vs. '95 E320 wagon? Know mechanic in VA? sgart W124 E,CE,D,TD Class 11 04-07-2010 08:52 PM
    e320 wagon brabus g36 W211 E-Class 6 07-07-2008 09:49 AM
    1997 E320 Check Engine Light - Misfire gradyjohnson W210 E-Class 8 04-10-2007 12:38 PM
    How did I do ? '02 E320 Wagon rl1856 W210 E-Class 3 09-11-2005 09:29 AM
    E320 Misfire/Fuel smoke at idle & steady throttle Guest (MBNZ) W124 E,CE,D,TD Class 4 12-20-2001 07:13 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome