Mercedes e300 td problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 02-02-2008, 01:20 AM Thread Starter
BenzWorld Newbie
Date registered: Feb 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Mercedes e300 td problem

Recently been through about 3 radiators and fans etc - initial problem thought to be the plastic cowling around the fan which was getting dragged into the fan and then smashing the radiator. Problem then found to be the water pump was not running true so caused belt movement which would lead to the broken fan and rad. Water pump changed however the vehicle is fine at high revs and when stationary it can be revved as hard and as fast as possible, although when on the move and kickdown or hard accelerating is applied above 3,000 rpm results in a squeal similar to a belt slipping ( which is the same noise as what it made before it smashed the fan and rad up). Any ideas??
Ollie Baker is offline  
Sponsored Links
post #2 of 5 (permalink) Old 02-02-2008, 08:59 AM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,507
Mentioned: 9 Post(s)
Quoted: 1055 Post(s)
Hard to hear the problem over the Internet, but belt tensioner on those cars are common problem. Did you change it during the repair?
This way, or another you might want to remove the belt and check all the components for play.
Kajtek1 is online now  
post #3 of 5 (permalink) Old 02-03-2008, 05:19 AM
BenzWorld Elite
Date registered: Jan 2004
Vehicle: 1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Location: Ocean Isle Beach, NC
Posts: 3,467
Mentioned: 0 Post(s)
Quoted: 30 Post(s)
Bad motor mounts can cause a misalignment in that area.

sokoloff is offline  
post #4 of 5 (permalink) Old 02-23-2009, 11:51 AM
BenzWorld Newbie
Date registered: Apr 2007
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Post Check your Alternator

I had heard a funny noise at idle, upon inspection it was difficult for me to distinguish where that noise was coming from but the alternator was high on the suspect list. Later that day I was driving, went to make a turn and noticed that the power steering was out, shortly thereafter, the battery charge indicator and coolant temperature level indicator were both beaming and the temp started to climb rapidly. I shut her down right away and popped the hood to find that the pulley of the alternator had come completely off of its press fit shaft, the serpentine belt had wrapped itself into a birds nest, a couple of blades came off the fan and cut the radiator up in a couple of spots...major sigh...
I found a replacement alternator from r & z alternator with the pulley. pulled the radiator and brought that to a radiator guy who is suggesting that he can fix it but doesn't think the repair will last and recommends buying a new one from the dealer because he can't seem to find the correct radiator for this car through his channels. Dealer wants $549.00, awesome. A new fan, also a dealer only part was $86.00...
Anybody else had an experience similar? Any advice offered would be greatly appreciated!!!
1999 E300 TurboDiesel
warmthesea is offline  
post #5 of 5 (permalink) Old 02-23-2009, 12:22 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,507
Mentioned: 9 Post(s)
Quoted: 1055 Post(s)
Check the Internet dealers like Duval or MB of Anaheim for new radiator price.
Kajtek1 is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    How much oil do i need to service a Mercedes E300 TD S3201994 W210 E-Class 1 10-28-2007 01:02 PM
    1995 Mercedes E300 Diesel POS For Sale/Wanted/Trade/Giveaway 1 05-27-2007 03:47 PM
    E300 Turbocharger Problem husk W210 E-Class 1 08-26-2005 12:26 AM
    1998 E300 TD Low Beam Problem Grenada W210 E-Class 3 12-08-2004 06:54 PM
    E300 Rust Problem tmerc65 W210 E-Class 1 06-24-2003 12:11 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome