Limp Home Mode - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-06-2008, 06:16 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool Limp Home Mode

Car: Merc. C 220 elegance 1994 petrol Auto UK model
Problem : Limp Home Mode
Turn ignition key = engine starts = idle climbs up to 1000 RPM then goes
into L.H.M. = switch of ignition = restart and the same thing happens.
the car used to travel approx. 15 miles before it went into L.H.M but by quickly turning the ignition
On/Off while driving you would get another 2 miles or so, I then lost interest and put the car on hold for a year
and bought a 1995 E200 petrol estate this had to have a head gasket replaced and now has a problem which is:
when cold and first started it drives fine but after a few minutes of running the idle becomes lumpy intermittidley
and feels like its firing on 3 until it picks up speed then its ok , meaning it drives fine on motorways etc until you stop at a junction and need to drive off again also I'm sure I can sometimes hear faint backfires when driving off from a standstill.
could it be the coils for the spark plugs breaking down and causing the excess fuel to explode.the fuel consumtion appears to have increaced.
thanks

Brian
bbrreid is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 01-17-2008, 05:58 PM
BenzWorld Junior Member
 
Date registered: Nov 2007
Vehicle: CLK320 sport
Location: Shropshire (UK)
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Limp mode

I had simlar problems with my CLK320. Replaced mass air flow meter & brake pedal switch after having diagnostics done by independant but the problem still persisted. In the end I bit the bullet & took it to MB main dealer. Best thing I ever did, they cleared all the stored fault alarms & found that the throttle body was faulty, car has been fine since this was replaced. Hope this helps.
CLK320rob is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
s600 limp home mode getonit W140 S-Class 13 10-06-2010 01:57 PM
CLK Limp Home Mode!!! Median C209/A209 CLK-Class 5 10-19-2007 03:20 AM
Limp home mode? rlbmd2006 W203 C-Class 0 08-27-2007 10:27 AM
Safe Mode/ Limp Home bendont V-Class 10 04-27-2007 07:16 AM
Limp home mode billreddrop W210 E-Class 0 11-23-2006 09:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome