Wiper, windows and rear defrost out on 300TE - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 01-02-2008, 11:29 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2007
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Wiper, windows and rear defrost out on 300TE

I unwittingly had my wipers on while they were stuck in heavy ice and snow.
Now the wipers do not work at all. In addition, the power windows will not work and the rear window defroster doesn't start.

Is it possible (I really hope) that the fuse has blown to these items?
I can't understand how the fuse would blow on all these since the fuses (I think) are all separate.

Any advice would be appreciated.
riles27 is offline  
Sponsored Links
post #2 of 2 (permalink) Old 01-02-2008, 11:33 AM
BenzWorld Elite
Date registered: May 2005
Vehicle: '07 GL320CDI
Location: Albuquerque
Posts: 5,070
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
300TE is a W124 chassis

It's pretty common on wagons this age for the wiring harness to the tailgate to fail where it's been flexing for years and years. It's on the left side.

Some people attempt repair, but I just replaced the whole thing with a new one, which was about $110.

Kent Christensen
'07 GL320CDI
lkchris is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Rear wiper and window defrost weoner W123 E,CE,D,CD,TD,TE Class 5 11-18-2007 01:13 AM
    rear wiper motor, rear lenses and hood felt wanted for W124 (88 300TE wagon) davidascher For Sale/Wanted/Trade/Giveaway 4 07-24-2007 06:30 PM
    Radio/rear defrost nendyar Audio & Telematics Forum 1 04-12-2006 12:15 PM
    91 300TE climate/defrost problem (with pass airbag) gmadden001 W124 E,CE,D,TD Class 1 04-16-2005 07:41 PM
    Rear Defrost Problem Guest (MBNZ) W202 C-Class 2 11-17-2001 10:20 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome