ML 320 Power Steering Failure - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 01-01-2008, 09:59 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Jan 2008
Vehicle: 1999 ML 320 130k Miles
Location: Los Angeles
Posts: 20
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
(Thread Starter)
Smile ML 320 Power Steering Failure

Hi All,
I have a '99 ML 320 with a power steering issue. I had what can only be desribed as a catastrophic failure of the P/S system. One minute fine then with a whine the system went down and I could hardly steer. Looked under the hood and although the fluid was leaking it was hard to locate the source as it was dark. Anyone have a thought ? Am I looking at a new pump or a couple of hoses and clips ?
Thanks for looking.
JF
jomiji47 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 01-01-2008, 06:18 PM
BenzWorld Newbie
 
Date registered: Jan 2008
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
You are going to have to replace the hose that goes from the P/S cooler to the rack and pinion. There has been several DTB's and/or recalls. If you take it to the dealer they will know exactly what you are talking about. If you keep running the pump dry you will need a new pump but a new line should be fine. Get that sucker fixed ASAP .
CaliCoast is offline  
post #3 of 5 (permalink) Old 01-01-2008, 07:58 PM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Sounds like a blown hose, but you may also need a new pump depending on how far you drove it after it failed. Hopefully you didn't? But if you did then go ahead and drive it to the mechanic and bring both checkbooks. Otherwise have it towed in.

Take care and enjoy the ride,
Greg

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #4 of 5 (permalink) Old 01-01-2008, 09:00 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,915
Mentioned: 2 Post(s)
Quoted: 591 Post(s)
Yeah, the pumps are pretty popular, we get a lot of calls on 'em.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #5 of 5 (permalink) Old 01-02-2008, 02:49 AM
BenzWorld Elite
 
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
first you need to find out where its leaking from. although the lower hose is common, it could be the seal on the resovoir, could be the pump, anything
Streetglower is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Power Steering Failure dmico2 W163 M-Class 8 07-28-2007 06:32 PM
    Power Steering Failure... orlandotrader W163 M-Class 4 10-19-2005 10:36 AM
    Power Steering Failure knudsenr W163 M-Class 1 01-24-2005 08:35 AM
    Power Steering Belt Failure? Indy Joe R170 SLK-Class 1 05-01-2002 02:57 PM
    OT: E 320 power failure? Chris(LE) R170 SLK-Class 2 08-30-2001 05:44 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome