Start error - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-16-2007, 02:38 AM Thread Starter
BenzWorld Newbie
Date registered: Nov 2007
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Start error

I tried to start my A170 (around 7 years old) last night but it wouldnt start. When i put the key in the ignition and turn it, it just makes a sort of clicking noise, and the engine doesnt come on at all. The first time i tried the engine made a sound but stuttered and wouldnt start. Now it just makes this clicking noise, and a Start Error appears on the dash.

Does anyone know what the likely problem would be? and How much its gonna cost?

Mk85 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 11-16-2007, 04:34 AM
BenzWorld Junior Member
Date registered: Nov 2007
Posts: 10
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Sounds like a flat battery if theres a clicking noise
davbro is offline  
post #3 of 3 (permalink) Old 11-16-2007, 05:25 AM
BenzWorld Member
Date registered: Mar 2007
Vehicle: 2007 Alpine Rain/Ash ML320 CDI
Location: Leonardtown, Maryland
Posts: 300
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
I agree. Your post and profile don't say your location but usually if it is the original battery and your weather is getting colder I'd say it's died.
CJzBenz is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    start error bonta V-Class 42 08-12-2011 06:43 AM
    Error Start hmb47 W901-905 Sprinter 5 04-23-2010 05:45 AM
    Start Error drkonek W163 M-Class 6 10-01-2006 09:19 PM
    Start Error DJ S420 W140 S-Class 4 08-23-2006 02:10 PM
    Start Error Hugo R170 SLK-Class 0 11-10-2002 03:26 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome