Sounds like fuel pump keeps starting and stopping? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 11-10-2007, 07:44 AM Thread Starter
BenzWorld Junior Member
Date registered: Jul 2006
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Sounds like fuel pump keeps starting and stopping?

1993 400SEL. I keep hearing what sounds like an electric motor starting and stopping. The sound comes from the right rear side of the vehicle as I'm driving. It runs for 3 or 4 seconds then stops, then starts again. Sometimes it will do this on and off cycling for the whole time I am driving. I started to notice that it sometimes starts when I have my foot on the accelerator, then stops when I take my foot off, that's why I thought it may be the fuel pump. Although, there are times when it cycles when I am just idling at a stop.
Anyone know what this might be??

Last edited by my400sel; 11-10-2007 at 07:47 AM.
my400sel is offline  
Sponsored Links
post #2 of 2 (permalink) Old 11-10-2007, 07:51 AM
BenzWorld Elite
MarcusF's Avatar
Date registered: Apr 2005
Vehicle: 2002 CLK430
Location: Southern California
Posts: 1,681
Mentioned: 2 Post(s)
Quoted: 3 Post(s)
When the fuel pump stops delivering fuel, the engine stops running. If the engine continues to run, it's not the fuel pump.
MarcusF is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1993 300E 3.2 problem starting, fuel pump relay again? FmrLCpl W124 E,CE,D,TD Class 14 12-06-2014 12:09 PM
    124 sedan starting problem...... fuel pump? euroamg W124 E,CE,D,TD Class 1 11-24-2007 10:19 AM
    Whats louder - Starting or Stopping? CDN-SLK55 R171 SLK-Class 24 03-15-2006 09:15 PM
    380sel where is the fuel pump fuse? have no power to pump meggala W126 S,SE,SEC,SEL,SD,SDL Class 3 08-02-2005 03:44 AM
    Q: "touch" starting, it sounds like the starter engages for 1/4 of a second then nothing benkokes R170 SLK-Class 0 12-11-2002 03:12 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome