c43 windows work intermittenly?????? - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 11-09-2007, 11:21 PM Thread Starter
BenzWorld Member
 
Date registered: Oct 2006
Posts: 74
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
c43 windows work intermittenly??????

My front windows are loosing touch here. the power mirror stops working on the driver side and so does the mirror wiggle the fuse and viola they work, not sure what is going on, anyone else have simular problems? I tried the search but nothing
Outlaw Latemodel is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 11-10-2007, 01:18 AM
BenzWorld Elite
 
Check Codes's Avatar
 
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Hey, OLM.
That's a new one on me. Just a couple of thoughts, hopefully they'll point you in the right direction if you don't hear from someone who's suffered through this.
First, seems like whenever there arises an odd electrical issue it is worth trying the 'Windows' approach and rebooting. Be sure you have your radio code and them disconnect the neg. battery cable, wait a bit and then reconnect it. Go through all the resets and see if that helps.
If not, wiggling the fuse suggests a couple of things, either a loose wire, a loose connection or a defective fuse. Easiest thing is to just replace it simply to eliminate that as a possibility. Then start working backwards from there. It is also possible that the connection issue is at the relay and by wiggling the fuse you cause an intermittent current disruption that results in a 'mini-arc' and - temporarily - closes the circuit.
Anyway, those are my initial thoughts, hope they prove to be of some use.
Take care and enjoy the ride,
Greg

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
post #3 of 5 (permalink) Old 11-18-2007, 12:28 PM Thread Starter
BenzWorld Member
 
Date registered: Oct 2006
Posts: 74
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
gregs210 thanks for your advise ill try the reboot thing, i can seem to be able to tell if there is a relay involved with this, I havent heard of the reboot thing before though, Thanks,
Outlaw Latemodel is offline  
post #4 of 5 (permalink) Old 11-22-2007, 04:12 PM Thread Starter
BenzWorld Member
 
Date registered: Oct 2006
Posts: 74
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
rebooted worked for a day yep same ol same ol, anyway is there a window relay? Kevin
Outlaw Latemodel is offline  
post #5 of 5 (permalink) Old 04-15-2008, 03:54 PM
BenzWorld Newbie
 
Date registered: Nov 2007
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
c43 window problem

Wow - timing is everything. I am having the same problems with my 99 C43 with 99K miles. It seems to affect either the front drivers or passengers window and side mirror (or once in a while) both at the same time. I re-boot the car by momentarily taking the cable off the negative battery terminal and wallah.... it mysteriously works again. In addition, the front 2 windows one touch feature (window all the way up or down) does not work. To roll the window down (or up), I need to keep holding the window button on the first detent of the toggle switch. Anybody else out there experienced this, or knows what might be amiss?

dc
davidrcarls is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Windows Won't Work Euro280SL W163 M-Class 2 08-23-2007 05:17 PM
    All 4 windows work!! DieselBear W123 E,CE,D,CD,TD,TE Class 3 03-03-2007 03:56 PM
    Lights alarm go off intermittenly! Help? fastmike99 General Mercedes-Benz 0 08-31-2006 11:44 AM
    Can't get any of my windows to work! Skeeter W123 E,CE,D,CD,TD,TE Class 23 05-21-2006 02:46 AM
    Glowplug light coming on intermittenly Adam_SD W140 S-Class 1 07-14-2005 01:54 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome