Electrical issue - please help me troubleshoot - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 10-30-2007, 10:04 PM Thread Starter
BenzWorld Member
Date registered: Jan 2003
Vehicle: 2006 CLS500 - Iridium Silver w/ AMG Sportline
Location: Denver, CO
Posts: 232
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question Electrical issue - please help me troubleshoot

99 C280 Sport. Driver's power seat backrest will go backward but forward maybe 1 out of 50-60 times the switch is pushed.

I called the dealer and they want to replace the seat motor to the tune of 6.5 hours @ $120.00/hr. + almost $300.00 in parts.

If the motor is bad, why would the backrest move at all, no matter how many times the switch is pushed? Does this sound more like a bad control switch on the door?

I want to fix the seat, but I don't want to just start replacing crap until it works.

Anyone been through this? Suggestions? Thanks in advance.
BBZLC is offline  
Sponsored Links
post #2 of 2 (permalink) Old 10-31-2007, 01:48 AM
BenzWorld Elite
Date registered: Jan 2007
Vehicle: 2002 honda civic (sold), 2009 Mercedes ML350
Location: Miami, florida
Posts: 1,344
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
the first thing needed is a short test to see if any fault codes are present. now I have never done a backrest motor for a car, have done seat motors but 6.5 hrs labor seems very excessive. again dont know what the warranty times are.

now the motor could be failing and will only work every so often, it doesnt have to fail completely for it to be bad. could be a bad contact in the switch as well. only way to know for sure is to check for power at the motor with the switch operated. if itsw a constant supply the motor is faulty, if not may be the switch.
Streetglower is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Electrical Issue Radiator W126 S,SE,SEC,SEL,SD,SDL Class 2 08-02-2007 09:40 AM
    Cold Start Issue: Help me Troubleshoot donniej W123 E,CE,D,CD,TD,TE Class 11 02-11-2007 05:53 PM
    Electrical issue HELP Sandro N W210 E-Class 1 12-27-2006 08:49 PM
    Electrical Issue intruder W123 E,CE,D,CD,TD,TE Class 16 11-18-2006 10:11 AM
    Electrical Issue? Pete1 W210 E-Class 2 07-25-2005 12:29 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome