1995 c280 ignition fault - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-28-2007, 10:31 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2007
Vehicle: I rather not publish that on this forum...:)
Location: Budapest
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Post 1995 c280 ignition fault

Dear All!

We had a serious problem with an MB. One of my acquaintance got the car, '95 C280. Since 3 years the car provides a malfunction, after few kms running w/o problem, then stops. Nobody was able to find the solution - YET NOR IN MB-BRANDSERVICE OF HUNGARY! So, no fault codes, (as he said) but time after time the problem started to be more serious. Decreasing kms, more stops. Already all of the known error specific parts had been changed connecting to this problem. F. ex. tank+supply pump, a year before the complete harness..etc. When I met that guy, I promised him to find out the way of the solution. I've asked all of my friends, and we've found a same engined MB providing the same problem. The solution was there the ignition coil's replacement. But there 2 times the same coil had been damaged-not after a long time. Someone got an information the coil is just an effect, the real problem is the ECU. So until we do not replace the ecu, the coils will be continuosly damaged. In our car 2 coils were defective, after exchanging them the car was good and it still is. (Since the exchange the car didn't run a greater test trip, but it is better than before.) The question is, does anybody have any information about this ecu related problem? 2 coils were defective... could it be that the coils are too weak?
Please help ASAP! colos85@freestart.hu
Thanks in advance!
Colos is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-28-2007, 11:27 AM
BenzWorld Elite
 
Diesel Benz's Avatar
 
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 213.050 & 906.633
Location: Europe
Posts: 10,342
Mentioned: 3 Post(s)
Quoted: 39 Post(s)
I believe there are three different W202 C280 cars, with two different engines. Since the issue seems quite specific to one model, I suggest you to give these details, if not more, to help experts considering just the specific car in question.
Diesel Benz is offline  
post #3 of 3 (permalink) Old 10-28-2007, 11:58 AM Thread Starter
BenzWorld Newbie
 
Date registered: Oct 2007
Vehicle: I rather not publish that on this forum...:)
Location: Budapest
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks for the suggestion!

The engine is M 104.941, chassis 202.028. The newer engine M 112.920 comes from 1997 as well as i know. Anyway, I'm going to get the VIN and the ECU part number!

Thanks, and best regards!
Colos is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
1995 C36 vs. 1995 C280 wiring harness M104-AMG W202 C-Class 6 01-24-2016 06:04 AM
1995 C280 Zapmehome For Sale/Wanted/Trade/Giveaway 0 10-15-2007 09:11 PM
1995 Ignition switch gone99 W124 E,CE,D,TD Class 0 01-21-2007 02:41 PM
C280 ignition died mo_c280 W202 C-Class 1 06-25-2006 11:05 AM
Diagnosing ignition fault 1990 560sec mikesmerc W126 S,SE,SEC,SEL,SD,SDL Class 3 11-25-2005 05:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome