remotes not working when CAR is cold - Page 4 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #31 of 32 (permalink) Old 11-09-2007, 03:32 PM
BenzWorld Senior Member
torontomichael's Avatar
Date registered: Oct 2007
Vehicle: 2008 e 350 4matic wagon
Location: Toronto area
Posts: 476
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Having read this thread through,and as a new MB owner,it seems to me that MB really has not CONSISTENTLY trained their technicians up to the demands of their car's technology. Inconsistent training = inconsistent application. We're not talking budget vehicles with MB; I think therefore we have a right to expect above-average consistently from their technicians.

Last edited by torontomichael; 11-09-2007 at 03:38 PM.
torontomichael is offline  
Sponsored Links
post #32 of 32 (permalink) Old 02-05-2008, 09:17 AM
BenzWorld Member
zam2000's Avatar
Date registered: Jan 2004
Vehicle: S, GL, Escalade ESV, my shoes
Location: OC
Posts: 283
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Originally Posted by scorpnaz7 View Post
wow, you paid way too much. I am having the same problem that you had, the car didn't recognize the key when the car was cold. I called a mercedes/bmw shop and they said that the green key is $200 and the eis is about $400 and 2 hours of labor. They said it will be about $850 out the door.
Going through the same deal w/ my 2003 S430. I'm being charged 3 hours of labor ($240), and the EIS for the S430 cost $525 (wholesale price, dealer quotes 650-700). No greenkey charge, as it's core exchange.

When I described the problem to the MB mechanic (MB Indy shop), it took him 2 min to response "EIS", and of the 2 min, 1:15 is for him to finish his cigarette . I'm told it's no uncommon for the EIS to fail, and if the car fail to response to lock/unlock, and key can't turn, most likely it's the EIS (provided that the battery is checked & in good condition).

If it takes 7 hours for dealer to find source of your problem, chance is they have some sort of monkey working on your car.
zam2000 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    need keys...remotes??? 430convertible C208/A208 CLK-Class 3 09-12-2006 08:57 PM
    A/C doesn't blow COLD air, stopped working. kamsbenz W210 E-Class 2 07-18-2005 09:10 PM
    one of my remotes doesnt work. i have two of them Carlo$ R129 SL-Class 6 03-09-2005 05:51 AM
    Its cold inside , the heaters dont seem to be working bmclean G-Class 3 01-15-2003 07:01 AM
    For all that have problem with your Remotes Chris Krikorian W163 M-Class 17 02-20-2002 05:03 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome