Strange Coolant Leak - Page 2 - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #11 of 17 (permalink) Old 09-01-2007, 07:31 PM
BenzWorld Member
 
ctbenztech's Avatar
 
Date registered: Aug 2007
Vehicle: ml430
Location: connecticut
Posts: 191
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
ive seen alot of oil sepage at the front between head and front cover
ctbenztech is offline  
Sponsored Links
Advertisement
 
post #12 of 17 (permalink) Old 09-01-2007, 10:18 PM Thread Starter
BenzWorld Member
 
trimaster1's Avatar
 
Date registered: Dec 2005
Vehicle: 1995 s500
Location: florida
Posts: 164
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I'll let U guys know the outcome next week. I'm taking the car to the shop on Tuesday. Thanks again 4 the replies.

Stay tuned...
trimaster1 is offline  
post #13 of 17 (permalink) Old 09-04-2007, 10:02 AM Thread Starter
BenzWorld Member
 
trimaster1's Avatar
 
Date registered: Dec 2005
Vehicle: 1995 s500
Location: florida
Posts: 164
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
It was the radiator cap. Thank goodnesss that's all it was.
trimaster1 is offline  
post #14 of 17 (permalink) Old 09-05-2007, 06:39 PM
BenzWorld Member
 
ctbenztech's Avatar
 
Date registered: Aug 2007
Vehicle: ml430
Location: connecticut
Posts: 191
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
thats great easy fixes are wonderful. but very odd ive never had one do that. congrats
ctbenztech is offline  
post #15 of 17 (permalink) Old 09-05-2007, 11:17 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,754
Mentioned: 9 Post(s)
Quoted: 1120 Post(s)
told'ya
Kajtek1 is offline  
post #16 of 17 (permalink) Old 09-07-2007, 11:09 PM Thread Starter
BenzWorld Member
 
trimaster1's Avatar
 
Date registered: Dec 2005
Vehicle: 1995 s500
Location: florida
Posts: 164
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by ctbenztech
thats great easy fixes are wonderful. but very odd ive never had one do that. congrats
Trust me, I was shocked myself. The mechanic said the cap was bad. The car's running fine now though.
trimaster1 is offline  
post #17 of 17 (permalink) Old 09-07-2007, 11:15 PM Thread Starter
BenzWorld Member
 
trimaster1's Avatar
 
Date registered: Dec 2005
Vehicle: 1995 s500
Location: florida
Posts: 164
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Quote:
Originally Posted by Kajtek1
told'ya

U sure did!


Quote:
Originally Posted by Kajtek1
Put good quality coolant and observe temperature gauge. Replacing the cap might be good idea as well.

This board is a GREAT reference tool. It's amazing how something as simple as a cap can do so much damage. My mechanic said this happens from time to time. he wasn't surprised at all...

Thanks again for your response!
trimaster1 is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Coolant leak trimaster1 W140 S-Class 3 09-04-2007 11:30 AM
    Coolant Leak pathogen W126 S,SE,SEC,SEL,SD,SDL Class 14 06-25-2007 09:36 AM
    Coolant leak tmryan W201 190-Class 2 02-20-2006 06:12 PM
    What does a coolant leak smell like with MB coolant? pcmaher W140 S-Class 3 09-27-2004 12:47 PM
    90 300E strange coolant level problem tomer W124 E,CE,D,TD Class 9 12-29-2003 10:40 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome