Problem with Model 200 E AUTO/ 1990 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-26-2007, 01:27 AM Thread Starter
BenzWorld Newbie
Date registered: Aug 2007
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Problem with Model 200 E AUTO/ 1990

When pressing break pedal the electrical supply to all dials cuts off. Will return to normal when pedal is released. Buzzing noise heard when this happens. Never happened before. Please can anyone help me. Thanks

Last edited by annehelene; 08-26-2007 at 02:11 AM.
annehelene is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    200 CE Auto - worth buying?? concrete brain unit W124 E,CE,D,TD Class 0 10-08-2006 12:33 PM
    nitros a 200 Auto philthompson W123 E,CE,D,CD,TD,TE Class 3 09-07-2006 11:46 AM
    auto trans problem 230 te 83 model thoth_9 W123 E,CE,D,CD,TD,TE Class 2 12-17-2004 10:34 PM
    help needed 200 auto chris uk General Mercedes-Benz 0 12-12-2004 08:35 AM
    Buying the right 1990 MB Model! bmackinnon General Mercedes-Benz 3 11-19-2004 12:53 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome