1999 ML320 BAS/ESP Check Engine after taking Steep "L" shaped Exit Ramp - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 10 (permalink) Old 08-18-2007, 08:54 AM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2007
Vehicle: 2007 Mercedes-Benz ML350
Location: Tampa, Florida
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation 1999 ML320 BAS/ESP Check Engine after taking Steep "L" shaped Exit Ramp

I purchased a 1999 ML320 recently which has low miles - only 46,000 miles. The current problem is puzzling. For everday driving on local roads no problems. Highway driving no problems. However, when we take this one exit ("L" shaped exit ramp) off the highway which slopes down and to the right and then we are downtown faced with several city blocks of traffic lights. Consistenly, every time, after taking this exit and going maybe a block or two, The dashboard gauges light up like a christmas tree. The BAS/ESP, Check Engine, Brake lights all come on and then the transmission only allows us to use the low gear to drive. After waiting a couple of minutes, turning the car off and then restarting the lights go out and the ML drives normally again. The Check Engine stays on, but eventually goes out after several restarts of the engine. Since purchasing this vehicle, I have replaced the brake pads back/front, front brake discs, MAS, vibration damper, transmission electrical plate, battery, rear crank seal, motor mounts, upper oil pan seal and of course not to mention labor. My mechanic is sending his kids through school off this vehicle repair. Any help would be appreciated. Thanks.

Last edited by jurga; 08-18-2007 at 10:25 AM.
jurga is offline  
Sponsored Links
Advertisement
 
post #2 of 10 (permalink) Old 08-18-2007, 03:26 PM
BenzWorld Elite
 
Michael Pillay's Avatar
 
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,281
Mentioned: 0 Post(s)
Quoted: 80 Post(s)
Get the codes read and post them. Advance Auto or Autozone will do it for free.

Mike
Michael Pillay is offline  
post #3 of 10 (permalink) Old 08-18-2007, 03:44 PM
BenzWorld Elite
 
johnhef's Avatar
 
Date registered: Mar 2007
Vehicle: Too Many
Location: Frederick, MD
Posts: 2,589
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to johnhef
just a guess from your description: lateral accelleration sensor, located under the center console.


Master Certified 10 years MB tech
1980 500SE Euro
1981 500SEL Euro
1982 380SEL
1983 500SEC Euro
1983 300TD
1984 500SEC - parts car
1984 300TD Euro
1985 190E 2.3-16 Euro
1986 190E 2.3-16
1986 190E 2.3-16 Lemons
1987 300D
1999 C230K
2003 C320T-4
2003 E55
johnhef is offline  
post #4 of 10 (permalink) Old 08-18-2007, 07:29 PM
BenzWorld Member
 
joshuajeeper's Avatar
 
Date registered: Sep 2006
Vehicle: 1985 Mercedes 300TD, 2014 GLK250 Bluetec
Location: Cameron Park, California
Posts: 196
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Garage
By any chance, do you pass a radio station or military facility or power station/plant? Weird interferences have been know to cause complaints like this.

1985 300TD - "Panzer Wagen" - undergoing full restoration (resto - mod)

2014 GLK250 Bluetec (Wife's Car)



Mercedes-Benz Master Certified Technician.

http://www.flickr.com/photos/joshuajeeper/
joshuajeeper is offline  
post #5 of 10 (permalink) Old 08-18-2007, 11:50 PM
BenzWorld Elite
 
Date registered: Aug 2006
Vehicle: 97SL500R129, 01ML320W163, 94E320W124 & 93500EW124
Location: So. Cal.
Posts: 2,919
Mentioned: 1 Post(s)
Quoted: 222 Post(s)
Twice it happened to my 01 320 (BAS/ESP light turned on). In both cases it was a defective stop light switch.
edcarls is offline  
post #6 of 10 (permalink) Old 08-20-2007, 08:33 AM
BenzWorld Elite
 
johnhef's Avatar
 
Date registered: Mar 2007
Vehicle: Too Many
Location: Frederick, MD
Posts: 2,589
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to johnhef
it could be the stop light switch but I'd expect it to do it much more often if it was. Why the car goes into limp home is a little odd though.


Master Certified 10 years MB tech
1980 500SE Euro
1981 500SEL Euro
1982 380SEL
1983 500SEC Euro
1983 300TD
1984 500SEC - parts car
1984 300TD Euro
1985 190E 2.3-16 Euro
1986 190E 2.3-16
1986 190E 2.3-16 Lemons
1987 300D
1999 C230K
2003 C320T-4
2003 E55
johnhef is offline  
post #7 of 10 (permalink) Old 08-20-2007, 08:12 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2007
Vehicle: 2007 Mercedes-Benz ML350
Location: Tampa, Florida
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I am going to get our mechanic to look at it one more time and focus on the aceleration sensor.
jurga is offline  
post #8 of 10 (permalink) Old 08-23-2007, 03:08 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2007
Vehicle: 2007 Mercedes-Benz ML350
Location: Tampa, Florida
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I finally got the codes:
ETC - 132,134,135,136,137 - all stored
ME2-SFI - P0720,P00700-106 - Not Defined
ESP - C1022(CAN Fault Control Unit w/ME-SFI),C1024(CAN Fault Control Unit ETC) - Stored
ESP - C1032(CAN Fault Control Unit Inst. Clust),C1030(CAN Fault Control Unit Transf Case) - Stored
AAM -
ICM - B1040(CAN Fault Control Unit MR engine control) stored
ICM - B1041(CAN Fault Control Unit Traction Systems) - stored
ICM - B1089(CAN FAult Control Unit Transfer Case) - stored

The mechanic drove it to the same exit ramp and got the same codes. He brought his laptop to read the codes. THe ML320 acted the same way when it exited from another steep ramp which curved to the right. He then cleared all of the codes and then drove a short distance before getting another set of codes. It only appears to happen in this area.....nowhere else. Could there be a latent electrical capacitance built up and not discharged yet from the lateral acelerator sensor ? He feels it might be the ESP Control Module
jurga is offline  
post #9 of 10 (permalink) Old 08-27-2007, 12:31 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Aug 2007
Vehicle: 2007 Mercedes-Benz ML350
Location: Tampa, Florida
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Only happens in certain part of downtown - hills or level ground - does not matter

An update........My wife just called and said that she bipassed the exit ramp and is in an area of downtown near the exit ramp on a flat surface road where we believe there is an area with a ton of radio/tv/satellite frequency in the area and as usual, the dashboard lit up like a christmas tree.....I am talking to her as we speak. We now definitely believe it has something to do with a magenetic/electrical surge because of the intense radio/tv/satellite frequency in the area.
jurga is offline  
post #10 of 10 (permalink) Old 08-27-2007, 12:46 PM
BenzWorld Elite
 
johnhef's Avatar
 
Date registered: Mar 2007
Vehicle: Too Many
Location: Frederick, MD
Posts: 2,589
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via AIM to johnhef
find another owner maybe though the mechanic with a similar vehicle and drive it though the same area and see what happens?


Master Certified 10 years MB tech
1980 500SE Euro
1981 500SEL Euro
1982 380SEL
1983 500SEC Euro
1983 300TD
1984 500SEC - parts car
1984 300TD Euro
1985 190E 2.3-16 Euro
1986 190E 2.3-16
1986 190E 2.3-16 Lemons
1987 300D
1999 C230K
2003 C320T-4
2003 E55
johnhef is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    BAS ESP and Check Engine Lights On dominic888 W163 M-Class 14 01-13-2009 08:12 AM
    Rolling backwards while on "D" on steep incline ProvingGrounds W140 S-Class 12 11-08-2006 12:56 PM
    Dealer found cause of my "BAS/ESP" light coming on, and its not the brake lamp switch... S4toML W163 M-Class 7 07-14-2003 05:58 PM
    Follow up on BAS/ESP/ABS lights and "B" service. Chris Krikorian W163 M-Class 0 10-25-2002 04:29 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome