pics of my car - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-16-2007, 09:47 AM Thread Starter
BenzWorld Member
 
Date registered: Oct 2006
Vehicle: 1983 300D- sold
Location: 2002 E320 4matic - black
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
pics of my car

I took the pics of my 2002 E320 at the dealership after I bought it!!

My 300D I miss terribly.
Attached Images
File Type: jpg Image 11.jpg (118.9 KB, 102 views)
File Type: jpg Image 22.jpg (172.2 KB, 106 views)
File Type: jpg Image 33.jpg (145.9 KB, 106 views)
File Type: jpg Image 66.jpg (152.0 KB, 101 views)
File Type: jpg Image 55.jpg (146.0 KB, 96 views)
farghenbenzer is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 08-17-2007, 10:53 PM
BenzWorld Member
 
Date registered: Aug 2007
Location: CT
Posts: 103
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I prefer the 300D better. Better made vehciles
Oracle12345 is offline  
post #3 of 4 (permalink) Old 08-17-2007, 10:56 PM
BenzWorld Elite
 
79Mercy's Avatar
 
Date registered: Oct 2006
Vehicle: 1979 280CE
Location: Jacksonville, Florida
Posts: 6,116
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
I would rather have the 300D than the E320.

'79 280CE with 226,000 miles
'76 240D 4 speed with 190,000
'85 300D Turbo with 266,000 miles


GONE but not forgotten
'76 300D with 195,300 miles
"83 300D with 174,000 miles

79Mercy is offline  
post #4 of 4 (permalink) Old 08-18-2007, 12:36 AM Thread Starter
BenzWorld Member
 
Date registered: Oct 2006
Vehicle: 1983 300D- sold
Location: 2002 E320 4matic - black
Posts: 56
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
I miss my 300D, but it had issues.
Truthfully, it looked a whole lot better than it drove. I drove it out to the Hamptons twice. The first time it was towed back. the second time I had to limp it home at 30mph. I tried to fix every thing that was wrong, but my mechanic, (a trusted friend ) said the transmission was on its way out, as well as rear end differential issues. I was looking at $6000.00 in repairs.
oh well.
farghenbenzer is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    New Car Pics HITWTOM W123 E,CE,D,CD,TD,TE Class 3 04-15-2007 08:35 PM
    Took Pics of car oallelsefailo W126 S,SE,SEC,SEL,SD,SDL Class 20 12-26-2006 03:23 PM
    Pics of my car.. My04230k W211 E-Class 0 11-30-2005 05:44 PM
    Hi again!! Ok Pics of my "hit" car... Anyone looking for a GREAT Parts car ? great motot ! BSS W123 E,CE,D,CD,TD,TE Class 10 12-12-2004 09:12 PM
    New pics of my car apegeneral W163 M-Class 9 02-03-2003 08:34 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome