a/c question - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 07-16-2007, 05:07 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2007
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
a/c question

a/c is not blowing cold. I evacuated an recharged using charging specs from WIS.
System gets cool not cold. Really hot days it just keeps up. Here are the specs.
Suction pressure 25 to 35 psig. High side much higher than specs should be. Running 232 to 260. Ambient temp 90. Air measured at center 52 degrees.
specs for high side 205psig. All fans are operational. The compressor does make pressure and heat. The specs from mercedes are for german measure so I had to convert pressure from BAR ande Celsius to Fahrenheit. I am suspecting either the compressor or expansion valve. Any thoughts?
sak384 is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 07-16-2007, 05:40 PM
Administratoris Emeritus
 
GeeS's Avatar
 
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,915
Mentioned: 2 Post(s)
Quoted: 591 Post(s)
Is this some sort of Mercedes?

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #3 of 5 (permalink) Old 07-16-2007, 07:21 PM
BenzWorld Extremist
 
Date registered: Dec 2005
Vehicle: Volvo 940GLE, GMC Suburban, Infiniti I30, Toyota Prius, VW GTI, MB SLK350, Lexus IS250
Location: San Jose, CA
Posts: 1,063
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Yes, it would help if you indicate the kind of car or add it to your profile. If the low side pressure is low and high side pressure is high, it would not be your compressor.

May be too much freon or the expansion valve is not opening enough. Is the thermal probe attached to the evaporator exit pipe correctly? Are any of the pipes or expansion valve itself frosted?
CalifSLK is offline  
post #4 of 5 (permalink) Old 07-18-2007, 02:48 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Jul 2007
Posts: 23
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Sorry about that 2002 e-430. Update i checked the total charge for this model on WIS. It calls for a total charge of 1000 grams. This equal to 2.2 lbs roughly. I weighed in the charge. at idle Suction pressure 43 psig. Discharge pressure 250 to 265.
outside ambient temp 94. Temp at center console 51. I believe the expansion valve is not fully opening. The pressures are close to specs. It will keep you at 95 any higher and you're just comfortable.
sak384 is offline  
post #5 of 5 (permalink) Old 07-18-2007, 03:45 PM
BenzWorld Extremist
 
Date registered: Dec 2005
Vehicle: Volvo 940GLE, GMC Suburban, Infiniti I30, Toyota Prius, VW GTI, MB SLK350, Lexus IS250
Location: San Jose, CA
Posts: 1,063
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
If you pour some water on the condenser, does the high side pressure go down? Seems a little over charged.
CalifSLK is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Resetting FSS question (error code question) TheOgre W163 M-Class 7 04-25-2008 02:37 PM
    Plug and Play NAV Question.First '05 Mod Question Stewart W163 M-Class 5 11-21-2005 09:00 AM
    Moron Needs help! A/c Recharge question and window question Jeepboi W124 E,CE,D,TD Class 5 07-26-2005 10:35 PM
    H&R Springs question --> General suspension question.. Vik W163 M-Class 4 01-31-2005 11:14 PM
    EZ PASS QUESTION / ENGINE TEMPERATURE QUESTION Chucky300 W220 S-Class 1 04-15-2003 07:23 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome