how to fix automatic antenna? - Mercedes-Benz Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 16 (permalink) Old 06-18-2007, 05:24 PM Thread Starter
BenzWorld Member
 
alexus.one's Avatar
 
Date registered: Jun 2007
Vehicle: C280 '97, SLK55 BRABUS AMG '05
Location: Brooklyn, NY
Posts: 259
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
Question how to fix automatic antenna?

Hey all, this is me again!
I decided to fix my antenna, the car had broken mast, so i bought mast installed it, and well ... the motor "sucked" out the pull ribbon fom the mast and that’s it.

It seams that there should be some sort of sensor that will stop the motor from pulling or pushing the ribbon but so far it works for ~24 seconds in each way. And for 24 sec it can eat the ribbon like at least 20 times the length i have (my ribbon is like 50cm)

So the question is, what do i do?
I see detachable controller box (the box that sits on the motor box) and it has 4 wires coming in, I’m sure that box should stop the antenna when it reaches the limit.

Any ideas would be very helpful!
Thanks a lot

PS: the car is C280 '97
alexus.one is offline  
Sponsored Links
Advertisement
 
post #2 of 16 (permalink) Old 06-18-2007, 06:03 PM
BenzWorld Extremist
 
Date registered: Dec 2005
Vehicle: Volvo 940GLE, GMC Suburban, Infiniti I30, Toyota Prius, VW GTI, MB SLK350, Lexus IS250
Location: San Jose, CA
Posts: 1,063
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I had this happened to me. I removed the antenna from the car, opened up the plastic take-up spool housing and removed the broken mast tail from the take-up spool. Then assembled it back, installed it back in the car, put in the new mast and it still works fine today.

It was a Takada antenna.
CalifSLK is offline  
post #3 of 16 (permalink) Old 06-18-2007, 06:06 PM Thread Starter
BenzWorld Member
 
alexus.one's Avatar
 
Date registered: Jun 2007
Vehicle: C280 '97, SLK55 BRABUS AMG '05
Location: Brooklyn, NY
Posts: 259
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
yea, but i just got new mast broken today, i thing the problem with braking 2nd antenna mast is that the motor should stop earlier then 24sec (probably when the mast can not go any futher) but in my case motor keeps ranning for full 24 sec and i need only like 10sec to pull out or retract the antenna.

do you know how car knows when to stop pulling the antenna?
alexus.one is offline  
post #4 of 16 (permalink) Old 06-18-2007, 06:14 PM
BenzWorld Extremist
 
Date registered: Dec 2005
Vehicle: Volvo 940GLE, GMC Suburban, Infiniti I30, Toyota Prius, VW GTI, MB SLK350, Lexus IS250
Location: San Jose, CA
Posts: 1,063
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
On some designs, there is a tension operated switch. The motor stops once the mast is under tension.
CalifSLK is offline  
post #5 of 16 (permalink) Old 06-18-2007, 06:26 PM Thread Starter
BenzWorld Member
 
alexus.one's Avatar
 
Date registered: Jun 2007
Vehicle: C280 '97, SLK55 BRABUS AMG '05
Location: Brooklyn, NY
Posts: 259
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
thats what i thought, but what if it does not stops, how can I fox that?
I assume there should be device that mesure Amperage on the motor and if the amount of amreirs is increased then the engine should stop, but what is responsible for that?

Could it be that box that is attached directly to the motor box? how can I chek if it works? Also ther do those 4 wires go?
alexus.one is offline  
post #6 of 16 (permalink) Old 06-18-2007, 07:20 PM
BenzWorld Extremist
 
Date registered: Dec 2005
Vehicle: Volvo 940GLE, GMC Suburban, Infiniti I30, Toyota Prius, VW GTI, MB SLK350, Lexus IS250
Location: San Jose, CA
Posts: 1,063
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by alexus.one
thats what i thought, but what if it does not stops, how can I fox that?
I assume there should be device that mesure Amperage on the motor and if the amount of amreirs is increased then the engine should stop, but what is responsible for that?

Could it be that box that is attached directly to the motor box? how can I chek if it works? Also ther do those 4 wires go?
So you removed the antenna from the car already? There are some extra wires near the antenna? Is this an after market antenna that someone had installed in the car and there were some extra wires left over?
CalifSLK is offline  
post #7 of 16 (permalink) Old 06-18-2007, 07:24 PM Thread Starter
BenzWorld Member
 
alexus.one's Avatar
 
Date registered: Jun 2007
Vehicle: C280 '97, SLK55 BRABUS AMG '05
Location: Brooklyn, NY
Posts: 259
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
all antena parts are original Hirshman parts, exept the mast itself.
there are no extra wires near antenna.. antenna has controller box that has microchip in it and that one has 4 wires comming in from somwhere (not sure from where, but definetly not the CPU, probaby radio)
alexus.one is offline  
post #8 of 16 (permalink) Old 06-18-2007, 08:02 PM
BenzWorld Extremist
 
Date registered: Dec 2005
Vehicle: Volvo 940GLE, GMC Suburban, Infiniti I30, Toyota Prius, VW GTI, MB SLK350, Lexus IS250
Location: San Jose, CA
Posts: 1,063
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Since the car is a '97, I would goes ahead and replace the antenna assembly; unless you are pretty handy and willing to open the antenna and take a look inside to see what is wrong.
CalifSLK is offline  
post #9 of 16 (permalink) Old 06-18-2007, 08:06 PM Thread Starter
BenzWorld Member
 
alexus.one's Avatar
 
Date registered: Jun 2007
Vehicle: C280 '97, SLK55 BRABUS AMG '05
Location: Brooklyn, NY
Posts: 259
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
(Thread Starter)
antenna asebmy might cost a bit too much for me (i didnt even see tham for sale)
I alredy opened it up, the mechanic part is totaly fine...
I realyy suspect the problem in "sensors", i could of try to debug that but i need to know info bout those incomming wires, if i will know what they do I woul be able to setup the situation at my home and debug it from there....

PS: Im gonna post fotos in cople of minutes
Attached Images
File Type: jpg main_assembly.jpg (52.0 KB, 118 views)
File Type: jpg DSCN2634.jpg (45.6 KB, 104 views)
File Type: jpg DSCN2635.jpg (45.1 KB, 102 views)
File Type: jpg DSCN2636.jpg (33.8 KB, 110 views)

Last edited by alexus.one; 06-18-2007 at 08:20 PM.
alexus.one is offline  
post #10 of 16 (permalink) Old 06-18-2007, 08:21 PM
BenzWorld Extremist
 
Date registered: Dec 2005
Vehicle: Volvo 940GLE, GMC Suburban, Infiniti I30, Toyota Prius, VW GTI, MB SLK350, Lexus IS250
Location: San Jose, CA
Posts: 1,063
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Great for you to take the attempt and good luck with it.
CalifSLK is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Antenna Fix JamieK W210 E-Class 127 02-06-2015 10:11 AM
    automatic antenna for '73 280sel 4.5 ldshull Vintage Mercedes-Benz 4 08-24-2006 03:52 PM
    Manual-to-automatic antenna conversion? Riquiscott Vintage Mercedes-Benz 2 09-21-2005 11:08 PM
    How to fix power antenna... this is what I have observed MBeige W123 E,CE,D,CD,TD,TE Class 1 04-25-2004 12:08 AM
    So about my antenna falling off, can I access the area under the antenna and fix this myself? Forrest R170 SLK-Class 2 09-27-2001 02:21 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome