Automatic problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-13-2007, 03:18 PM Thread Starter
BenzWorld Junior Member
Mercedes E320 Avantgarde's Avatar
Date registered: Jun 2007
Vehicle: Mercedes E320 Avantgarde 1997
Location: Norway
Posts: 8
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Automatic problems

I have a E320 1997 w/ 5 speed automatic that I have some problems with.
When it's cold, it's locked in 1. gear and I must have 2800-2900 rpm. before it shift up (not good fore the engine), and under a secund it shift up to 3 gear.
I hope someone know this.
The oil is 1 year old.
It's a bad fault.
Mercedes E320 Avantgarde is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-13-2007, 03:58 PM
BenzWorld Elite
Check Codes's Avatar
Date registered: Mar 2005
Vehicle: '01-E320 & 02-ST2
Location: John 15:18-19
Posts: 31,634
Mentioned: 0 Post(s)
Quoted: 35 Post(s)
Hi, MBE320AV and welcome to the forum.

Benz transmissions are designed to delay upshifts when the engine is cold, but if this is new and different from what you normally see the first suspect is the fluid. You reference the oil as one year old, hopefully you're referring to the AT fluid.

When you had the fluid changed last, how did they do it? Was it a proper drain and fill with a new filter and the proper MB spec fluid or was it one of the quickie flush places or ???

There is also the possibility of one of the sensors out of range and there is also another circuit somewhere that fluid can leak into when a seal fails. The search function will reveal further details and none of these is horribly expensive.

If you fill out your profile someone in your part of the world may have a shop they can commend to you for proper and fair diagnosis.

Also, general questions are great in this general forum, but when you have issues specific to your model it's best to post in that native forum, in this case the W210 sedan forum.

Take care and enjoy the ride,

Socialism is a philosophy of failure, the creed of ignorance, and the gospel of envy; its inherent virtue is the equal sharing of misery. (Winston Churchill)
Check Codes is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Automatic transmission problems? Mr:S55AMG-01 W220 S-Class 0 07-10-2006 01:59 AM
    Automatic Transmission problems on my 300sd Teradoc W116 S, SE, SEL, SD Class 0 10-19-2005 11:52 AM
    Automatic Climate Control Problems gotallthetoys W211 E-Class 1 09-20-2004 10:31 AM
    automatic transmission problems Guest (MBNZ) W126 S,SE,SEC,SEL,SD,SDL Class 1 05-06-2002 10:08 AM
    Automatic Trans Problems Guest (MBNZ) W201 190-Class 0 09-11-2000 06:00 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome