AC / Ec Button is on and no cold air C 280 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-12-2007, 08:03 AM Thread Starter
BenzWorld Newbie
Date registered: May 2007
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
AC / Ec Button is on and no cold air C 280

Ac/ec button is constantly on and no cold air is coming out in 1997 C 280 Mercedes Benz.
This car had a new compressor put in about 9 months ago worked fine for 3 months then the car was parked for 6 months. After that the Ac worked but not great so we injected dye to find a leak but we could not so we drained the system then recharged worked Ok for about 2 weeks. Now the EC button is on all the time and no cold air is coming out.
I tried to reset it using the same resets for E320 but I could not get any DTC codes I also could not see sensor number 4 although I saw all the other sensors
elbasha is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    1998 mercedes 320, ml , a/c blows freezing cold air,then hot air bevleblanc W163 M-Class 14 11-27-2012 06:24 PM
    1983 280 se cold start sensor help!!! hystrung W126 S,SE,SEC,SEL,SD,SDL Class 0 04-03-2006 07:13 PM
    Cold engine C-280 ilong_99 W202 C-Class 3 09-19-2004 02:06 PM
    air conditioner stopped blowing cold air 86 420 sel W126 S,SE,SEC,SEL,SD,SDL Class 10 07-20-2004 11:26 AM
    280 cold start problem Ernest T Bass G-Class 3 01-08-2004 08:48 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome