Transmission trouble (help) - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-09-2007, 10:31 AM Thread Starter
BenzWorld Junior Member
Date registered: Apr 2007
Vehicle: 1998 E-320 Wagon
Location: Maryland
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Transmission trouble (help)

On my '98 E-320 wagon, under certain conditions, noise similar to worn-out brake pads scraping soon-to-be-worn-out rotors emanates from where the transmission meets the drive shaft. It started suddenly, has been intermittent, and occurs (a) in park and neutral, and (b) when driving in 1st and 2nd; above that, all is smooth and silent. The car has 114K miles on it, no codes are displayed, no fluid leaks, though without a dipstick I haven't checked the level. My shop can't get to me until Monday so I thought I would see if anyone here has an explanation. Searching this forum for 'transmissions', I found quite a few threads describing similar problems, but no solutions, other than 'replace the tranny'. Maybe, but not yet. It isn't anything like the catalytic converter rattling, or motor mounts, or a cracked flex-disk. Thanks in advance for any help.

Tom Swift is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Transmission trouble Syracuse315 W201 190-Class 4 01-05-2007 08:02 AM
    Transmission TROUBLE! 84 380 sl peter g R/C107 SL/SLC Class 5 09-09-2005 02:50 AM
    Transmission trouble stroessel W163 M-Class 5 06-27-2005 09:19 AM
    transmission trouble Wyatt W124 E,CE,D,TD Class 2 05-31-2005 06:29 PM
    404 transmission trouble tomsantoli Unimog 1 03-23-2005 08:07 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome