Anyone know what could cause this? - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-03-2007, 08:13 AM Thread Starter
BenzWorld Junior Member
Date registered: Dec 2006
Vehicle: 1997 E320
Location: England
Posts: 7
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry Anyone know what could cause this?

Posted a couple of weeks ago asking for help with my 97 E320. It kept stalling and sometimes failing to restart .Couple of guys recommended that i should change the CPS.

I changed the CPS this morning, the car seemed to be fine. Wife decides to take it down to the shops , she came out of the shops and the car refused to start.
I drove down to see what the trouble was, whilst the car was been cranked over the red & green lights in the rear view mirror were flashing like crazy and then continued to flash for about 30 seconds after i turned off the ignition. it refused to start.

Tried locking and unlocking a few times to no avail . I could hear a relay clicking under the hood ,leaving the ignition turned on i lifted the hood to see where the noise was coming from and it appeared to be somewhere under the inlet manifold.

Wife then turned the ignition key and the car fired up.WTF!! We then took it for a drive and it ran great, but we didn't dare turn the ignition off.

Has anybody had problems with the immobiliser on the E320?
motty is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-03-2007, 06:16 PM
BenzWorld Elite
Mercedes Benz of Florida's Avatar
Date registered: Dec 2006
Vehicle: 2000 Mercedes-Benz S500. Sold: 2000 C230K, Sold: 1997 Porsche 944S
Location: New York City, NY, USA
Posts: 1,271
Mentioned: 0 Post(s)
Quoted: 26 Post(s)
Send a message via Yahoo to Mercedes Benz of Florida
no doubt your going to have to get the car into a repair shop.
Don't go replacing and changing stuff out you don't need to.
Its too frustrating and too expensive.
You definitely have an Electrical problem, but that can me a lot of things
Grounded wire, bad sensor, electrical wiring.
Pay the small $100 trouble shooting fee and then at least you have a firm
idea of what it is.
Its a 1997 so its bound to have a few quirks.
Good Luck!

New York City, NY
Richmond County

United States of America
Mercedes Benz of Florida is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome