CL500 misfire - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-12-2007, 05:02 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2006
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
CL500 misfire

Having trouble with misfire that dealer has not been able to solve.
Codes say misfire cylinder 1, and MAF sensor fault. Dealer has:
Changed MAF sensor
Swapped plugs, coils etc, still says cylinder 1
Swapped fuel injectors, ditto
Compression test OK
Initially misfired when accelerating hard, but now much worse.
I have car back again from the garage, with maybe its the ECU?
Anyone any ideas
kelticcare is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Misfire Rajinder_1 R129 SL-Class 7 08-12-2007 04:53 AM
    Would 2002 CL500 Wheel fit on 03 CL500 Sport??? JKRD101 C215 CL-Class 5 06-13-2005 04:30 PM
    Luke or anyone, 02 CL500 wheels fit 03 CL500 with sport? JKRD101 The Discount Tire Direct Tire, Wheel, Brake & Suspension 1 05-24-2005 12:45 PM
    Misfire mttbtt G-Class 13 09-11-2003 09:48 AM
    misfire pwebs W210 E-Class 2 06-21-2003 01:38 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome