1982 Turbo Transmission problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 01-25-2007, 04:21 AM Thread Starter
BenzWorld Newbie
 
Date registered: Dec 2006
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Angry 1982 Turbo Transmission problem

tansmission would not shift to third. I had to slide it through nuetral for the oil to move and then back into third. Motor seesm to have plenty of power (although started very very slow until turbo kicked in). Second phase, i ran it hard to see if oil would move to help shift -- well >>>>>>>>>> Heard a pop and now will not shift out of first.

Other than being stupid. what have i done - is this the torque converter seal and what was going on before ?

Thanks for helping
New World is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Topic Author Forum Replies Last Post
TRADE 1984 300D turbo for 1982-1987 turbo wagon (300td) DieselKraut For Sale/Wanted/Trade/Giveaway 1 10-06-2015 11:50 AM
Transmission problem, '87 190D 2.5 Turbo luxurious W201 190-Class 4 10-20-2005 06:50 AM
'85 300D Turbo - Transmission Problem? Atomicn W123 E,CE,D,CD,TD,TE Class 8 08-02-2004 11:21 AM
1982 300D Turbo Sedan - problem with brakes dcarl43677@aol.com W123 E,CE,D,CD,TD,TE Class 1 02-03-2003 07:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 

Title goes here

close
video goes here
description goes here. Read Full Story
For the best viewing experience please update your browser to Google Chrome