Backfiring thru exhaust, engine cuts. - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 01-06-2007, 03:11 AM Thread Starter
BenzWorld Newbie
Date registered: Jan 2007
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Cool Backfiring thru exhaust, engine cuts.

Hi, I have a 1984 280SE and recently replaced fuel filter, replaced fuel pump, replaced battery, replaced fuel tank (had rust in the other one) replaced plug leads. Engine ran fine for six months after all of this. Engine cold starts fine. After warm up acts like too much Christmas spirit (stops and starts on the run) until I have to stop for lack of power. Engine continues to run. I have to put into Park or Neutral and idle for up to ten minutes until you can sense the power returning, then no more problems. WAIT! If I let the car sit for more than three hours I get a repeat of the same. I have now replaced exhaust system blown out from a backfire.

Local service dealer cannot find anything wrong as car was on best behaviour when I took it there. He replaced fuel filter again and car ran OK for 24 hours. Now back to its old tricks.

Please, can anyone help? I am thinking checking ground from battery, replacing coil, replacing plugs and putting spirit in the fuel in case I have water in there somewhere.

Really frustrated!
Koya is offline  
Sponsored Links
post #2 of 3 (permalink) Old 01-06-2007, 06:37 AM
BenzWorld Member
mybenz123's Avatar
Date registered: May 2006
Vehicle: w123 300tdt
Location: Belleville, NJ
Posts: 362
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I'm no expert but it sounds like a cracked distributer cap.
I guess if you have replaced it you can ignore this.

mybenz123 is offline  
post #3 of 3 (permalink) Old 01-06-2007, 07:19 AM
Administratoris Emeritus
GeeS's Avatar
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,831
Mentioned: 1 Post(s)
Quoted: 544 Post(s)
Welcome to BenzWorld, Koya! I would try a good old-fashioned tune-up, if you haven't already -- plugs, wires, cap, rotor. It couldn't hurt.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Engine Not Starting/Cuts out while driving masterstgy W163 M-Class 3 04-12-2006 05:18 PM
    Engine Cuts Out Kain W201 190-Class 3 04-06-2006 12:44 AM
    300TE engine randomly cuts out bjestico W124 E,CE,D,TD Class 3 12-16-2005 01:33 PM
    engine cuts out? gravel C208/A208 CLK-Class 1 12-03-2005 01:48 PM
    300te engine cuts out didi General Mercedes-Benz 3 05-29-2004 08:15 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome