Engine Trouble - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 12-31-2006, 10:31 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2006
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Engine Trouble

Hello Gang:

I own a '95 E320 with 270K miles. I've had no major trouble with this car until now.
When I start the car in the morning, it starts easily as always, then it begins cycling up and down almost, "rhythmically". Every second or so the rpm's rise and fall. After 2-3 minutes of driving, this symptom subsides. Occasionally, after the car is warmed up, it does the same sort of thing in reverse. When I attempt to accelerate, the cycling starts; when I get off the accelerator, the car idles normally.

In addtion to these symptoms, (which are bad enough), the cruise control system and the feature that allows the power windows to open fully with one click have stopped working.

Any ideas?


Last edited by petro2005; 12-31-2006 at 10:50 AM.
petro2005 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    2.6 - Engine Dies - and trouble starting manymercsmike W201 190-Class 8 12-25-2006 10:39 AM
    Cold Engine Trouble? VR6MAN W126 S,SE,SEC,SEL,SD,SDL Class 4 06-12-2006 09:50 PM
    engine trouble 4x4abc G-Class 15 11-10-2005 09:44 PM
    Need help with engine start trouble Gobs W126 S,SE,SEC,SEL,SD,SDL Class 3 09-17-2005 06:03 PM
    Engine trouble MB E300TD W210 E-Class 1 03-30-2005 08:30 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome