Please read. Here is an idea for stalling problems with 190E - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 12-03-2006, 02:17 PM Thread Starter
BenzWorld Newbie
Date registered: Dec 2006
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Exclamation Please read. Here is an idea for stalling problems with 190E

Recently i have been having a problem with stalling (occasional) for my 93 190e. The first time was durring a bad rain storm stopped at a light. I pushed it to the side of the road and everything seemed fine (everything including pump worked correctly) but no start. I added gas and pushed it to a parking lot and just for giggles tryed to start it again and waalaa.
It ran fine for about 3 weeks, then the other day did it again twice. I noticed that i had to keep defrosting my windows due to excesive moisture outside and then it ran fine.
The next day i tryed to start it all day and no dice. (it was also raining and very damp). Then today (a perfectly clear day) it started up first try and has been running strong all day.
I think yall see where this is going. I have been reading on all kinds of forums about this same type of problem with people changing pumps, relays, filters ect. only to have the problem get better but still be there and people just putting up with it. Luckily i live on a hill that seems to get more foggy during storms or high mosture.
I still have yet to find the exact culperate but here is my thought. I used to be a electronics tech in alaska. On the rainy island of kodiak i found many situations where cannon plugs with excess corrosion, which is white/powdery, would turn almost to a toothpaste consistancey during high moisture days and cause false problems due to short/lack of voltage. I have only had this car for a few months and do not have any manuals or wiring diagrams for it yet so here is thoughts.
The problems for my car include:
1. Fuel guage that works sometimes, and pegs to full at other times.
2. SRS light binked during one rain storm.
3. Raidio with speakers coming on and off at will plus dimmer sometimes goes on/off.
4. Stalling when its excessively damp out.
5. Outside temp guage worked then showed it getting hotter and hotter till it just stopped working all together.
So my question to everyone is, For those who know the electrical systems, are there any common plugs or whiring harnesses for any of the above mentioned issues. I think that if we could find a plug or grouping of wires that is in common, we may find corrotion and it may help me and tons of baby benz owners.
kurtieg21 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 12-04-2006, 11:19 AM Thread Starter
BenzWorld Newbie
Date registered: Dec 2006
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
or what about

What about corroded or weak grounds? I am going to check for that next.
kurtieg21 is offline  
post #3 of 3 (permalink) Old 12-04-2006, 08:32 PM
BenzWorld Elite
Ruudje's Avatar
Date registered: May 2004
Vehicle: 2008 Outback 2.5 XT, 1999 A4 1.8T, 1980 244 GL
Location: Tustin CA
Posts: 1,768
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Send a message via Yahoo to Ruudje
Originally Posted by kurtieg21
What about corroded or weak grounds? I am going to check for that next.
What about your alternator? Radio on and off and dimmer stuff looks like a retarted power delivery. Does it give constant power? Sometimes alternators keep on going despite the fact you're slowly going out. Mine gave up twice and died right away.... when I had my 1991 VeeDub Golf back in NL, I had similar issues when driving over 50 MPH in heavy rain.

I'd check the grounds as well. Cold weather is harsh on a car. Even a Benz.

“One who conquers himself is greater than another who conquers a thousand times a thousand on the battlefield.”
Ruudje is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    190E with LPG conversion - stalling problems Stevieleeds W201 190-Class 0 04-05-2006 09:07 PM
    190e Stalling m4411b W201 190-Class 4 01-06-2006 01:35 PM
    1990 190E 2.6 Stalling benz190E2.6 W201 190-Class 2 05-23-2004 03:38 AM
    '89 190E 2.6 Stalling & Now Not Starting dm4x2000 W201 190-Class 3 04-05-2004 01:12 AM
    1991 190E 2.6 stalling, etc. Guest (MBNZ) W201 190-Class 3 05-23-2002 04:51 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome