C240 - Headlight Washers not working!! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 11-25-2006, 01:30 PM Thread Starter
BenzWorld Newbie
Date registered: Nov 2006
Vehicle: C240 Elegance Auto Estate
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question C240 - Headlight Washers not working!!

Having series of Electrical issues, latest headlamp power wash does not work but results in pool of washer fluid on the floor. Can anyone help or advise? Thanks

Last edited by Tecko; 11-25-2006 at 01:33 PM.
Tecko is offline  
Sponsored Links
post #2 of 4 (permalink) Old 11-25-2006, 01:32 PM
BenzWorld Elite
flyboyike's Avatar
Date registered: May 2003
Vehicle: 2012 Focus SE
Location: Ormond Beach, FL
Posts: 7,697
Mentioned: 1 Post(s)
Quoted: 67 Post(s)
Most likely a bad pump.

Felicita e un bicchiere di vino con un panino.
flyboyike is offline  
post #3 of 4 (permalink) Old 11-25-2006, 07:19 PM
Administratoris Emeritus
GeeS's Avatar
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,831
Mentioned: 1 Post(s)
Quoted: 544 Post(s)
Well, if you wind up with a puddle, I'd check and make sure the washer hose is connected properly.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #4 of 4 (permalink) Old 11-26-2006, 06:11 AM
Lifetime Premium Member
Musikmann's Avatar
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 5 Post(s)
Lifetime Premium Member
The the pump and washer hose both sound like good possibilities. There is also an outside chance that the nozzles have become clogged, but I think an unlikely one, if neither work.

Have a friend watch from the front when you activate them - if they at least open, this will help you narrow it down from among our suggestions.

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    need COMAND/CD/SOMETHING for C240 2001 thebenzpirate General Mercedes-Benz 1 06-07-2006 08:11 AM
    2001 C240 for Sale paraslice11 W203 C-Class 0 02-07-2003 01:42 PM
    Problems with 2001 C240 gbull W203 C-Class 5 10-18-2002 10:52 AM
    C240 2001 rims Guest (MBNZ) The Discount Tire Direct Tire, Wheel, Brake & Suspension 1 02-27-2002 09:39 PM
    2000 S4 vs. 2001 C240 Guest (MBNZ) W203 C-Class 7 09-23-2000 07:36 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome