no power to windows or radio HELP !!!!!! - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 10-18-2006, 03:18 PM Thread Starter
BenzWorld Junior Member
wvh187's Avatar
Date registered: Aug 2006
Posts: 40
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
no power to windows or radio HELP !!!!!!

last night i was working on my car tryint to fix the cruise control i installed the new switch and it still did not work... so i put everything away then today i went to me car and started it and my windows dont roll down and my radio does not work... Everything but the radio and windows work... i checked all the fuses i have been sitting here tryin to look for bad connections but i cant find anything ... can anyone please help me if they have had this problem or know what to do ..... HELPPPPPPPPPPPP
wvh187 is offline  
Sponsored Links
post #2 of 4 (permalink) Old 10-18-2006, 05:17 PM
BenzWorld Elite
MarcusF's Avatar
Date registered: Apr 2005
Vehicle: 2002 CLK430
Location: Southern California
Posts: 1,681
Mentioned: 2 Post(s)
Quoted: 3 Post(s)
I don't know what kind of car you have, but that may prove helpful. Also, my best guess is either (1) you unplugged something, either consciously or unconsciously, and forgot to plug it back, or (2) something got shorted. It really sounds to me like #2. How many fuse boxes does your car have and did you check every fuse in each box?
MarcusF is offline  
post #3 of 4 (permalink) Old 10-19-2006, 09:39 AM
BenzWorld Member
gold300grey560's Avatar
Date registered: Nov 2005
Vehicle: 300se 560sel
Location: London England
Posts: 107
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
you may want to check the voltage of the capacitors located in the fuse box. if not the capacitors, you may have a dodgy relay...i had non-working windows and £23 spent at the stealership provided me with a new relay and capacitor which solved the problem. also check that the fuses don't have hairline cracks, or oxidisation of the ally of the fuses. change the fuses to the copper type. as a last measure disconnect the battery, wait 30 secs and the re-connect. good luck.

Just look at that car, don't it look great just sittin there?
gold300grey560 is offline  
post #4 of 4 (permalink) Old 10-19-2006, 01:01 PM
Administratoris Emeritus
GeeS's Avatar
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,831
Mentioned: 1 Post(s)
Quoted: 544 Post(s)
As MarcusF indicated, model/year would be helpful.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    no power to windows or radio HELP !!!!!! wvh187 W201 190-Class 6 10-19-2006 09:16 PM
    help no power to radio or windows wvh187 Audio & Telematics Forum 0 10-18-2006 03:17 PM
    power windows 230emercedes General Mercedes-Benz 8 08-15-2005 07:30 PM
    power windows..... barberhauler W123 E,CE,D,CD,TD,TE Class 2 08-05-2005 05:47 PM
    Power windows !!!!!!!!!!!!! CEOG G-Class 1 08-04-2005 04:13 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome