Need Help With My C280's Bose Stereo - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-16-2006, 02:59 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2006
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Need Help With My C280's Bose Stereo

Hello,

If anyone can help me out with this, I'd be eternally grateful. I own a 1999 C280 with the Bose stereo, 6 CD changer etc. and for the last year or so, it's only been working intermittently. The problem that arose was that the buttons would, seemingly without reason, stop responding or work differently (ie the CD button would change the radio station when pressed). This wasn't a big enough problem to address in the past since they would usually go back to normal working order after a short period of time. That said, for the last month or so the stereo has been completely unresponsive and none of the buttons work. It's stuck on an FM station at a very low volume and I don't know what could be the cause of this progressive problem. If anyone has any insight on this matter, please let me know.

Thanks!



Jay
jsikura is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-16-2006, 07:31 PM
BenzWorld Elite
 
Date registered: Aug 2005
Vehicle: 2003 S430 Sport Edition
Location: Curacao, Netherlands Antilles
Posts: 1,321
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
My 1999 C280 radio volume will not stabilize if i turn up the volume it will blast or sometimes it fade and takes time to comeback. I have it on one level the volume on Monday and on Saturday i have to manage to turn it down.

My MB tech has to take the radio out of the dash and air clean inside. They say it might be the transitors are dirty with dust or other particles.

Eddie
Curacao is offline  
post #3 of 3 (permalink) Old 10-19-2006, 05:22 PM Thread Starter
BenzWorld Junior Member
 
Date registered: Oct 2006
Posts: 5
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thanks Eddie. That doesn't sound too disparaging so hopefully my problem's not dissimilar.


Jay
jsikura is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    Bose Stereo? Michael Pillay R170 SLK-Class 5 09-10-2006 05:56 PM
    2000 bose stereo? remjob1210 W210 E-Class 0 09-06-2006 09:11 PM
    Bose Stereo Problems hansduker W163 M-Class 6 08-13-2004 12:30 PM
    Specs on bose stereo Castorpimp Audio & Telematics Forum 4 08-13-2004 10:09 AM
    BOSE fading from stereo-mon-stereo Bora20 W163 M-Class 13 07-23-2003 02:46 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome