99 C280 trans problem - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-11-2006, 01:46 PM Thread Starter
BenzWorld Newbie
Date registered: Oct 2006
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
99 C280 trans problem

Hi all, our 88,000 mile C280 would not budge today when I started it up and put it in Drive. It has been towed to the local dealer. Up until this morning it has driven well and it has been a real pleasure to drive. I would like to know what to expect from the dealer. They have been performing the maintenance on our car. Thank you, Ron Anthony in MD.

Just got a call from the dealer, we were concerned our car might need a new
transmission. Not so, dealer rep said a sensor or plug under the tranny was leaking fluid and that caused it to slip and not engage when in drive. That and another part will run us about $500 but better than another
O on the end. By the way, also said we need front wheel bearings for $700 and ball joints for $500. Do those prices sound right? TIA, Ron.

Last edited by RonAn; 10-12-2006 at 08:35 AM.
RonAn is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Trans Problem 300D 1981 My1Firstone W123 E,CE,D,CD,TD,TE Class 17 02-15-2011 03:53 PM
    trans problem? phillymb75 C215 CL-Class 2 01-30-2006 10:02 PM
    Possible Trans Problem? HELP! aerosnout W124 E,CE,D,TD Class 6 05-09-2005 08:40 AM
    auto trans problem DIEHARD W140 S-Class 4 08-01-2004 06:26 AM
    auto trans problem Andrzejek W202 C-Class 0 07-14-2004 08:46 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome