ECU problem in my 2003 ML320 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 09-30-2006, 12:00 AM Thread Starter
BenzWorld Junior Member
Date registered: Sep 2006
Vehicle: 2002 ML320
Location: Melbourne, Australia
Posts: 32
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ECU problem in my 2003 ML320

I bought the 2003 320 few months ago. Performed well in the first few months then recently it started developing shifting problems. Basically it will stop shifting and lock itself in the lowest gear. The lights in the dash indicating what gear the car is in will be blank. When the problem occurs, also the Check Engine, the ABS and the ESP lights will be on. I told it to the service centre. They hooked it up to the computer and couldn't tell what was causing the problem. They reset the ECU and it worked for couple of days then locked itself in lower gear again. Now they tell that the ECU has been water damaged and will need replacing. I am not sure how can the ECU be water damaged because I live in a dry climate (Dubai). Although I traveled overseas for a month and the car was getting washed every second day during this period. Maybe water got in somehow and damaged the ECU because the car just sat stationary for a month. Did someone had a similar problem liks this before? I find it difficult to accept that Benz will have such a bad design for the location of the ECU that it can get damaged just by washing the car. Could it be just a software problem? Although they did reset the software twice already. I am getting quoted more than $2,000 for the parts. Ouch
karmannghia60 is offline  
Sponsored Links
post #2 of 3 (permalink) Old 09-30-2006, 01:32 AM
BenzWorld Member
Date registered: Mar 2006
Posts: 109
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
I'm no expert but i highly doubt that ECU has had water damage to it.. ECU is sealed water tight i believe...
s430owna is offline  
post #3 of 3 (permalink) Old 09-30-2006, 09:24 AM
BenzWorld Elite
Michael Pillay's Avatar
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,272
Mentioned: 0 Post(s)
Quoted: 78 Post(s)
You might want to check out the w163 forum. Maybe a search will of that forum will help.

Michael Pillay is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    PULLEY+ECU for Slk 200K evo special edition year 2003 molder2k R170 SLK-Class 2 08-22-2006 06:02 AM
    wanted 2003 sl 500 ecu cnterline For Sale/Wanted/Trade/Giveaway 0 04-13-2006 06:41 PM
    2003 cl 55 amg - is it worth getting the ecu reprogrammed? markwojo General Mercedes-Benz 1 02-09-2006 09:11 AM
    Where is the ECU on a 2003 SL55? JosanK R230 SL-Class 7 02-23-2005 02:13 PM
    Resetting ECU? WIll it cure starting problem? ramorris R170 SLK-Class 2 07-16-2004 01:28 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome