Problems after full mercedes service - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-24-2006, 09:50 AM Thread Starter
BenzWorld Newbie
Date registered: Sep 2006
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Problems after full mercedes service

We recently bought a 1990 300CE and thought we would do the proper thing and take it to our local mercedes garage for a full maintainance service. The garage rang up to say that there was a slight misfire which we may not have noticed but they would look at. 3 days later after trying everything (new coil pack, new leads, plugs replaced in service, new injectors etc) they suggest a problem with the valves or head gasket which to fix would be very expensive. We opted to leave this as our understanding from them was that the problem was un-noticable (we certainly hadnt noticed any misfiring before the service took place) We have now got the car back and it runs terribly, misfiring at idle and low load, but running normally at high speed. What have they done to our car to cause this problem during its service? Any ideas would be greatfully recieved.
bnz300ce is offline  
Sponsored Links
post #2 of 4 (permalink) Old 09-24-2006, 05:59 PM
BenzWorld Elite
Michael Pillay's Avatar
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,274
Mentioned: 0 Post(s)
Quoted: 78 Post(s)
Where are you located? Maybe a member close to you could suggest an independant mercedes service shop.

Michael Pillay is offline  
post #3 of 4 (permalink) Old 09-24-2006, 06:26 PM
Administratoris Emeritus
GeeS's Avatar
Date registered: Aug 2002
Vehicle: 2021 SL770
Location: Fountain Hills, AZ
Posts: 44,831
Mentioned: 1 Post(s)
Quoted: 544 Post(s)
Welcome aboard bnz300ce! I don't know what to tell you -- that's just sad. It just goes to reaffirm my 'if it ain't broke, don't fix it' philosophy.

"If spending money you don't have is the height of stupidity, borrowing money to give it away is the height of insanity." -- anon
GeeS is offline  
post #4 of 4 (permalink) Old 09-24-2006, 08:28 PM
BenzWorld Elite
Kajtek1's Avatar
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,536
Mentioned: 9 Post(s)
Quoted: 1070 Post(s)
If the shop messed it up, you have to give them a chance to do it right.
If they fail, you can take it to another mechanic for diagnosis.
Statement from another mechanic that it is their action costing the problem would be excellent, but very hard to get.
Kajtek1 is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    Full Mercedes Tech CDs ONLINE... Braingears W124 E,CE,D,TD Class 41 10-07-2006 10:19 AM
    Is there a "W126 for dummies" list of the full 90K service listed anywhere on this site or the web? brucemendel W126 S,SE,SEC,SEL,SD,SDL Class 4 12-24-2005 02:19 PM
    Mercedes USA problems? In for service 22 times in 2 years Devaclis General Mercedes-Benz 21 05-09-2005 06:34 PM
    C43 problems at full throttle Trigger W202 C36 AMG, C43 AMG 4 01-20-2004 04:39 PM
    Warning about full service gas stations Venk R170 SLK-Class 9 01-14-2001 09:18 AM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome