Xenon problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 08-23-2006, 01:16 PM Thread Starter
BenzWorld Newbie
Date registered: Aug 2006
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Xenon problems

Just got a xenon upgrade kit for my 99 e320. anyways i plugged in the kit to try them out (before a formal install) and the bulbs flickered for about 1/2 a second, then went out. I unplugged them, checked all the connections, put in a different bulb (in case mine was bad) turned the lights back on and still the flicker, then nothing. Any help would be greatly appreciated.
Thank you
alternativesurfer is offline  
Sponsored Links
post #2 of 4 (permalink) Old 08-23-2006, 01:59 PM
BenzWorld Elite
lnguyenh's Avatar
Date registered: Jan 2004
Vehicle: SL500, CL55, E350, E320
Location: Northern VA, USA
Posts: 3,207
Mentioned: 0 Post(s)
Quoted: 4 Post(s)
Check your ballasts. They might go bad.
lnguyenh is offline  
post #3 of 4 (permalink) Old 08-23-2006, 04:29 PM Thread Starter
BenzWorld Newbie
Date registered: Aug 2006
Posts: 2
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Yea, they are brand new, and are both doing it. These arent cheap ones off the web either, i got them directly from Phillips brand Hella. Anyways, prob still happening.
alternativesurfer is offline  
post #4 of 4 (permalink) Old 08-24-2006, 10:35 AM
BenzWorld Elite
Diesel Benz's Avatar
Date registered: Dec 2005
Vehicle: 222.132 & 221.122 & 212.025 & 906.633
Location: Europe
Posts: 10,320
Mentioned: 3 Post(s)
Quoted: 32 Post(s)
Search e.g. W211 forum, this issue has been discussed there, perhaps in audio & telematics too. The W210 must be quite similar. You have to program the car with star diag so that the car knows xenons are present.
Diesel Benz is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Similar Threads
    Topic Author Forum Replies Last Post
    What exactly is the second Xenon on a Bi-Xenon setup, given the low beams are xenon, is it the Man-Du-Ru-Gas W163 M-Class 3 01-28-2008 05:00 PM
    problems replacing 4000K Xenon HID to 8000K ? EUCLK200 C208/A208 CLK-Class 8 03-22-2005 06:27 AM
    Philips 6000K xenon / hid conversion problems....pls help NYCPiLoT747 General Mercedes-Benz 1 01-25-2005 03:01 PM
    XENON HEADLIGHT PROBLEMS CarlssonE430 W210 E-Class 2 06-26-2003 01:47 PM
    2003 ML Xenon Light and Navigation Problems cgmike10 W163 M-Class 0 11-17-2002 08:26 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome