FM Radio reception problems - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-19-2006, 05:27 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jul 2006
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question FM Radio reception problems

I have a C180 Komp (W203) with factory fitted Mercedes own brand (Becker?)Audio 10 CD unit. All FM radio reception is in MONO despite the STEREO indicator illuminating on the front panel. All four speakers are working in stereo when playing a CD so it is not a spkr wiring issue. I am also getting AM reception and most FM stations, so presumably antenna in rear window is ok. I have the owners manual for the unit but cant find anything about this problem. Anyone have this problem or know of any menu tweaks I might do????Otherwise faulty head unit??
Thanks a lot,
John M
Ireland.
maddenj is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-19-2006, 12:49 PM
BenzWorld Elite
 
Jayhawk's Avatar
 
Date registered: Aug 2005
Vehicle: S500/W220/2000
Location: Lawrence, KS (USA)
Posts: 21,652
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Hey John! You might get better reception if you post this on the "Audio.." fourm here. Welcome!!
Attached Images
 

Don't believe everything you think
Jayhawk is offline  
post #3 of 6 (permalink) Old 07-20-2006, 05:43 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Arrow maddenj

Quote:
Originally Posted by maddenj
Otherwise faulty head unit??
Hi John,

I'd look at the head unit first, and also post this according to Jayhawk's suggestion.

Welcome!
M

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #4 of 6 (permalink) Old 07-20-2006, 05:44 AM
Lifetime Premium Member
 
Musikmann's Avatar
 
Date registered: May 2006
Vehicle: 2001 E320 - Brilliant Silver/Ash: 107,000+
Location: West Virginia, USA
Posts: 17,193
Mentioned: 0 Post(s)
Quoted: 6 Post(s)
Lifetime Premium Member
Arrow Jayhawk

Quote:
Originally Posted by Jayhawk
Hey John! You might get better reception if you post this on the "Audio.." fourm here. Welcome!!
Where did you find the welcome mat - that is NICE my friend!

M

Mercedes Benz - Das beste oder nichts!
Musikmann is offline  
post #5 of 6 (permalink) Old 07-20-2006, 11:03 AM
BenzWorld Elite
 
Jayhawk's Avatar
 
Date registered: Aug 2005
Vehicle: S500/W220/2000
Location: Lawrence, KS (USA)
Posts: 21,652
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Quote:
Originally Posted by Musikmann
Where did you find the welcome mat - that is NICE my friend!

M
Thanks. Feel free to copy it to your Pictures folder, and use it liberally w/ noobies.

Don't believe everything you think
Jayhawk is offline  
post #6 of 6 (permalink) Old 10-10-2006, 01:00 AM
BenzWorld Newbie
 
Date registered: Aug 2006
Vehicle: Mercedes 180C Classic
Location: Sydney Australia
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Send a message via Skype™ to StuartS
Quote:
Originally Posted by maddenj
I have a C180 Komp (W203) with factory fitted Mercedes own brand (Becker?)Audio 10 CD unit. All FM radio reception is in MONO despite the STEREO indicator illuminating on the front panel. All four speakers are working in stereo when playing a CD so it is not a spkr wiring issue. I am also getting AM reception and most FM stations, so presumably antenna in rear window is ok. I have the owners manual for the unit but cant find anything about this problem. Anyone have this problem or know of any menu tweaks I might do????Otherwise faulty head unit??
Thanks a lot,
John M
Ireland.
Hi John

I have a similar problem with very poor AM reception but good FM. The local radio shop tells me they believe the power pack to the aerial is faulty. Apparently there is a power pack that boosts the aerial signal from the rear windscreen. But I also saw a post, which I cannot find now, from someone who said they had trouble after fitting UV screening on the rear windscreen. I am looking for a solution too.
cheers

Stuart
StuartS is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Similar Threads
    Topic Author Forum Replies Last Post
    radio reception jah_mama C208/A208 CLK-Class 5 07-09-2004 04:31 PM
    AM RECEPTION FROM RADIO DURIM69 General Mercedes-Benz 1 06-27-2004 12:12 PM
    No AM radio reception, again Stewart W163 M-Class 1 07-05-2002 08:11 AM
    AM radio reception...help! JimG W163 M-Class 1 03-31-2002 05:57 PM
    Radio Reception.... SchneiderIS W163 M-Class 25 03-29-2002 10:40 PM

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome