Oil filter cover does not open for ML-55 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 06-09-2006, 07:18 PM Thread Starter
BenzWorld Extremist
sstomcat's Avatar
Date registered: Jun 2006
Vehicle: ML-55 - 2000,
Location: Spring, TX
Posts: 902
Mentioned: 1 Post(s)
Quoted: 20 Post(s)
(Thread Starter)
Question Oil filter cover does not open for ML-55

I'm trying to open my oil filter cap and it does not turn by hand.....I guess it is too tight any recommendations/tools?
sstomcat is offline  
Sponsored Links
post #2 of 2 (permalink) Old 06-09-2006, 07:39 PM
BenzWorld Elite
Michael Pillay's Avatar
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,273
Mentioned: 0 Post(s)
Quoted: 78 Post(s)
Check/search the w163 forum. I think there was a thread on this just a little while ago.

Michael Pillay is online now  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome