huge drop in fuel economy 1981 300D - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 06-01-2006, 12:37 PM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2006
Vehicle: 1981 123 300D
Location: Hunsville, AL USA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Question huge drop in fuel economy 1981 300D

I am brand new to this forum. Wish I had found this forum long ago!!!

I have a 1981 123 300D with 355,000 miles. Highway fuel economy had been at 28 mpg and in town at about 24 mpg for the last 10 years. Fuel economy has been dropping steadily over the last two years and is now at about 20 mpg highway and in-town.

Any thoughts on the problem and solution.

Air filter is new, fuel filters have about 6,000 miles on them. Doesn't seem to be a loss of power on the road. The glow plug light operates properly. The only noticeable new engine quirk is that the engine runs very rough when cold starting in the morning but smooths out after about 15 seconds. And over the past year I have experienced that the engine won't always shut off from the ignition. I have to pop the hood and shut if down manually.

Thanks in advance
paddle is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 06-01-2006, 01:39 PM
BenzWorld Extremist
 
smallfence's Avatar
 
Date registered: Jan 2006
Vehicle: 1981 240D
Location: PA
Posts: 858
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
it might also help to post your question in the W123 forum...other than that I'm not sure what to tell you right now!

20,000mi on biodiesel and counting!
smallfence is offline  
post #3 of 5 (permalink) Old 06-01-2006, 07:15 PM
BenzWorld Elite
 
Kajtek1's Avatar
 
Date registered: Dec 2005
Vehicle: W211 E320 Bluetec R129 SL500 - $1300 car ........ Ford F350 6l
Location: CA Bay Area
Posts: 31,777
Mentioned: 9 Post(s)
Quoted: 1123 Post(s)
I did diesel purge on my old 300d in the past and it helped. When was the time you changed injector, or injector tips?
They have kits on ebay.
Kajtek1 is offline  
post #4 of 5 (permalink) Old 06-01-2006, 09:10 PM
BenzWorld Extremist
 
smallfence's Avatar
 
Date registered: Jan 2006
Vehicle: 1981 240D
Location: PA
Posts: 858
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Quote:
Originally Posted by Kajtek1
I did diesel purge on my old 300d in the past and it helped. When was the time you changed injector, or injector tips?
They have kits on ebay.
good suggustion. maybe the car is also due for a valve adjustment?

the shut off problem is common...usually related to a leaky vacuum line. See here http://www.benzworld.org/forums/w123...st-2-days.html
that should get you started but it doesn't sound that bad

20,000mi on biodiesel and counting!
smallfence is offline  
post #5 of 5 (permalink) Old 06-02-2006, 06:15 AM Thread Starter
BenzWorld Newbie
 
Date registered: Jun 2006
Vehicle: 1981 123 300D
Location: Hunsville, AL USA
Posts: 3
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Thankyou. the vacuum pump has been replaced and the brakes work fine. the shut off valve may very well be the culprit unless there is a leaky line.

The injector tips have not been replaced. The glow plugs were replaced and converted to pencil type units. The precumbustion chambers may also need cleaning.

paddle is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome