Rear window motor help for 99 E320 - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 05-27-2006, 10:53 AM Thread Starter
BenzWorld Junior Member
Date registered: May 2006
Posts: 6
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
Rear window motor help for 99 E320

Does anyone have a photos of the motor/cable assembly? Something happened with one of the cables in the rear driver side window. The motor is fine. I could roll the window down but not up. I was able to pull the window up and it slides down by itself after some vibration. I took the door panel off and one of the cables (I assume cable that pulls window up) off and was just floating in there. I found where it belongs in behind the motor but I have no idea where the other goes. Its has a floating spring on it.

Any help would be appreciated.
mkiii90t is offline  
Sponsored Links
post #2 of 3 (permalink) Old 05-27-2006, 11:32 AM
BenzWorld Elite
Michael Pillay's Avatar
Date registered: Oct 2003
Vehicle: 500SE AMG, E350 4matic, GL 450
Location: Michigan
Posts: 5,274
Mentioned: 0 Post(s)
Quoted: 78 Post(s)
You probably would have better luck posting this in the w210 forum. Maybe do a search of that forum as well.

Michael Pillay is offline  
post #3 of 3 (permalink) Old 05-28-2006, 07:13 AM
BenzWorld Elite
Date registered: Jan 2004
Vehicle: 1959 220S cabriolet, 1983 240D original owner, 1999 E300 turbo diesel, 1988 560SL, 2003 SLK320
Location: Ocean Isle Beach, NC
Posts: 3,467
Mentioned: 0 Post(s)
Quoted: 30 Post(s)
Common problem. Regulator needs to be replaced. Part is under $100. In addition you need to buy the rivets to reinstall it. You need to drill out 3 or 4 rivets to get the old one out.

Actually if you go to the 210 Forum as suggested, there is a sticky in the DIY topics that covers the repair. I actually carry the procedure around in the trunk of my car along with a couple of 2 x 4 pieces that I have fabricated to hold the window up if it ever fails me on a trip somewhere.

'99 E300TD 93,000 miles
sokoloff is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome