ML 270CDI Transmission problems - Mercedes-Benz Forum

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 05-17-2006, 09:55 PM Thread Starter
BenzWorld Newbie
Date registered: May 2006
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
ML 270CDI Transmission problems

Hi Guys,

I have a 2000mdl ML 270cdi with 100,000 klms on the clock.

The engine is free reving between gear change 3 and 4 and the car has gone into limp home mode a couple of times (sticks in 2nd gear) but it will come out of limp mode when i turn the car off and restart it which seems odd, as i thought if there was a problem with the transmission it should stay in limp mode untill problem is fixed.

Took the car to the dealer and they did the dianostic test and they cant find a problem, they said it could be 100s of things but dont know what it is,They also checked the tansmission fluid and that was fine. they sugested pulling the tranny apart to see if they can find the problem (sounds expensive)

Has anyone else had similar problems with a ML and what was the problem?

hope someone has the answers,

best regards,
fromcoyle is offline  
Sponsored Links

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply

Register Now

In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode

    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On


    Title goes here

    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome