S-500 with possible tranny problem - Mercedes-Benz Forum

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 04-05-2006, 08:44 PM Thread Starter
BenzWorld Newbie
 
Date registered: Apr 2006
Posts: 4
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
(Thread Starter)
S-500 with possible tranny problem

[:o)]
Hello everyone:
I'm a first time user. I'll try to be brief and hope I get some of your attention to render a response.

I own a 1996 S500 with 147,000 miles...great car. Check engine light diagnosed as needing a mass air flow sensor--not yet replaced. Now, when starting our, especially going upa grade, I hear a clunk, clunk sound before it shifts. Is this a possible tranny problem? I've not had the trans fluid replaced.
I want to keep the car but hopefully the repair(s) will be reasonable.
Thank you
Bob
BIGBOB is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 04-05-2006, 10:18 PM
Will Moderate For Cigars
 
cmitch's Avatar
 
Date registered: Apr 2005
Vehicle: 2002 ML320, 2005 S430 4MATIC, 2010 F150 Crew Cab
Location: City on the TN River
Posts: 10,691
Mentioned: 3 Post(s)
Quoted: 204 Post(s)
Lifetime Premium Member
RE: S-500 with possible tranny problem

You own a Mercedes, repairs will seldom be reasonable, especially for a tranny. You may just need a fluid change. I do remember reading something in this forum about tranny problems in the earlier S classes. I think the trannys were too weak for the heavy cars.

Do a search in the related S Class forum.
cmitch is offline  
post #3 of 4 (permalink) Old 04-06-2006, 08:47 AM
BenzWorld Elite
 
Jayhawk's Avatar
 
Date registered: Aug 2005
Vehicle: S500/W220/2000
Location: Lawrence, KS (USA)
Posts: 21,652
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
RE: S-500 with possible tranny problem

I hate to hear those two things in the same sentence: S-500 and tranny problem.

Before you do anything re. tranny, replace your MAF. That could very well be causing your "apparent" tranny problem. It won't be cheap either--mine cost me $900 w/ labor ($450 parts & $350 labor, roughly) plus tax and misc., a few months ago. I've never seen or heard anything about car too heavy for tranny, or hardly ever heard of any serious tranny problems w/ S-class.

Keep us posted.

Don't believe everything you think
Jayhawk is offline  
post #4 of 4 (permalink) Old 04-06-2006, 09:46 AM
Will Moderate For Cigars
 
cmitch's Avatar
 
Date registered: Apr 2005
Vehicle: 2002 ML320, 2005 S430 4MATIC, 2010 F150 Crew Cab
Location: City on the TN River
Posts: 10,691
Mentioned: 3 Post(s)
Quoted: 204 Post(s)
Lifetime Premium Member
cmitch is offline  
Sponsored Links
Advertisement
 
Reply

  Mercedes-Benz Forum > General Mercedes-Benz Forums > General Mercedes-Benz

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Mercedes-Benz Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











  • Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
     
    Thread Tools
    Show Printable Version Show Printable Version
    Email this Page Email this Page
    Display Modes
    Linear Mode Linear Mode



    Posting Rules  
    You may post new threads
    You may post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are On
    Pingbacks are On
    Refbacks are On

     

    Title goes here

    close
    video goes here
    description goes here. Read Full Story
    For the best viewing experience please update your browser to Google Chrome